summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pdm/Manifest3
-rw-r--r--dev-python/pdm/pdm-2.12.4.ebuild81
-rw-r--r--dev-python/pdm/pdm-2.13.3.ebuild115
-rw-r--r--dev-python/pdm/pdm-2.14.0.ebuild117
4 files changed, 0 insertions, 316 deletions
diff --git a/dev-python/pdm/Manifest b/dev-python/pdm/Manifest
index 46e4c3969fab..4dcb54929339 100644
--- a/dev-python/pdm/Manifest
+++ b/dev-python/pdm/Manifest
@@ -1,4 +1 @@
-DIST pdm-2.12.4.tar.gz 2598160 BLAKE2B 9eecae679a577c9d6172a07ad633be8b840ac5d972ad0e468b368dabc716203d10c5f0c78e87b815aa30af3be37f6370bcb6623fc5d272a52b6c3e4490112455 SHA512 12cabaff90f962ac195a484ea2bafa8a5ec9debdaf90b59b81d28eee51f854b9ac6d894e22a16c5ad8b69740c5df6a6573942a82c4ea5482819e60bc903c8358
-DIST pdm-2.13.3.tar.gz 2609678 BLAKE2B 58eb9fda4bc30fc37ef43b38fa140252242c22a062c4ddef49e90c0ece102cb36ea2186b02fb995a895c6eb80c0da9e602c42c15e83158b3e19fa5d0f55e8d6a SHA512 ea4b0e51d13effe8749a95237799de304047dcec8efc22a41d0985c97ff39447065a9fc84f4510b18055527dd64695bcee4129abcf34221573b2b9d39c2a3c92
-DIST pdm-2.14.0.tar.gz 2610646 BLAKE2B d0b6c6fc576315b1bcc81c2555731cc0945c0482d912dab9d26edae3bf24dc2c933afc8f9bfb72c482e40540892d1c53fc01d164578dad9245d3c54b72109849 SHA512 07f3b7840dc577d3884e1149c15c33e8618c4ab922ac7c5b69f0b32f8481c3532ca77a5a650cf33d32bdb4437610727894b55fa622b002d54144bbbf5e66483f
DIST pdm-2.15.0.tar.gz 2612107 BLAKE2B 51edda53cef30b84e29cc16eafed52e682e5ee50ba48a5e28821c40ababdc0dafe9b193a916c0451b1b463708da934f3f66ddf73f59f7d6f706f3c410fac0302 SHA512 0499ce2b7d48300a379ceaacd6ff5d107006929b8ab7bd017794d5802be8e807725b187a2aba4c11131c23db2acb626d1934d9f95621fde985a133391a6acf0d
diff --git a/dev-python/pdm/pdm-2.12.4.ebuild b/dev-python/pdm/pdm-2.12.4.ebuild
deleted file mode 100644
index 2275630b637f..000000000000
--- a/dev-python/pdm/pdm-2.12.4.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=pdm-backend
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python package and dependency manager supporting the latest PEP standards"
-HOMEPAGE="
- https://pdm-project.org/
- https://github.com/pdm-project/pdm/
- https://pypi.org/project/pdm/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-
-RDEPEND="
- dev-python/blinker[${PYTHON_USEDEP}]
- dev-python/certifi[${PYTHON_USEDEP}]
- >=dev-python/dep-logic-0.2.0[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/platformdirs[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- dev-python/truststore[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-python/pyproject-hooks[${PYTHON_USEDEP}]
- dev-python/requests-toolbelt[${PYTHON_USEDEP}]
- >=dev-python/unearth-0.12.1[${PYTHON_USEDEP}]
- <dev-python/findpython-1[${PYTHON_USEDEP}]
- >=dev-python/findpython-0.4.0[${PYTHON_USEDEP}]
- dev-python/tomlkit[${PYTHON_USEDEP}]
- dev-python/shellingham[${PYTHON_USEDEP}]
- dev-python/python-dotenv[${PYTHON_USEDEP}]
- >=dev-python/resolvelib-1.0.1[${PYTHON_USEDEP}]
- dev-python/installer[${PYTHON_USEDEP}]
- dev-python/cachecontrol[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-httpserver[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Internet
- 'tests/cli/test_build.py::test_build_with_no_isolation[False]'
- tests/test_project.py::test_access_index_with_auth
- tests/cli/test_others.py::test_build_distributions
- 'tests/models/test_candidates.py::test_expand_project_root_in_url[demo @ file:///${PROJECT_ROOT}/tests/fixtures/artifacts/demo-0.0.1.tar.gz]'
- 'tests/models/test_candidates.py::test_expand_project_root_in_url[-e file:///${PROJECT_ROOT}/tests/fixtures/projects/demo-#-with-hash#egg=demo]'
- # hangs on interactive keyring prompts
- tests/cli/test_config.py::test_repository_overwrite_default
- tests/cli/test_config.py::test_hide_password_in_output_repository
- tests/cli/test_config.py::test_hide_password_in_output_pypi
- # junk output, sigh
- tests/cli/test_others.py::test_info_command_json
- # why does it try to use python 2.7?!
- tests/cli/test_run.py::test_import_another_sitecustomize
- )
- [[ ${EPYTHON} != python3.10 ]] && EPYTEST_DESELECT+=(
- # test seems hardcoded to 3.10
- tests/test_project.py::test_project_packages_path
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -m "not network and not integration and not path" \
- -p pytest_mock
-}
diff --git a/dev-python/pdm/pdm-2.13.3.ebuild b/dev-python/pdm/pdm-2.13.3.ebuild
deleted file mode 100644
index 79d9646a54be..000000000000
--- a/dev-python/pdm/pdm-2.13.3.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=pdm-backend
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python package and dependency manager supporting the latest PEP standards"
-HOMEPAGE="
- https://pdm-project.org/
- https://github.com/pdm-project/pdm/
- https://pypi.org/project/pdm/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/blinker[${PYTHON_USEDEP}]
- >=dev-python/dep-logic-0.2.0[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/platformdirs[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- dev-python/truststore[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-python/msgpack[${PYTHON_USEDEP}]
- dev-python/httpx[${PYTHON_USEDEP}]
- dev-python/filelock[${PYTHON_USEDEP}]
- dev-python/hishel[${PYTHON_USEDEP}]
- dev-python/pbs-installer[${PYTHON_USEDEP}]
- dev-python/pyproject-hooks[${PYTHON_USEDEP}]
- >=dev-python/unearth-0.15.0[${PYTHON_USEDEP}]
- <dev-python/findpython-1[${PYTHON_USEDEP}]
- >=dev-python/findpython-0.6.0[${PYTHON_USEDEP}]
- dev-python/tomlkit[${PYTHON_USEDEP}]
- dev-python/shellingham[${PYTHON_USEDEP}]
- dev-python/python-dotenv[${PYTHON_USEDEP}]
- >=dev-python/resolvelib-1.0.1[${PYTHON_USEDEP}]
- dev-python/installer[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-httpserver[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Internet
- 'tests/cli/test_build.py::test_build_with_no_isolation[False]'
- tests/test_project.py::test_access_index_with_auth
- tests/cli/test_others.py::test_build_distributions
- 'tests/models/test_candidates.py::test_expand_project_root_in_url[demo @ file:///${PROJECT_ROOT}/tests/fixtures/artifacts/demo-0.0.1.tar.gz]'
- 'tests/models/test_candidates.py::test_expand_project_root_in_url[-e file:///${PROJECT_ROOT}/tests/fixtures/projects/demo-#-with-hash#egg=demo]'
- tests/models/test_candidates.py::test_find_candidates_from_find_links
- tests/cli/test_build.py::test_build_single_module
- tests/cli/test_build.py::test_build_single_module_with_readme
- tests/cli/test_build.py::test_build_package
- tests/cli/test_build.py::test_build_src_package
- tests/cli/test_build.py::test_build_package_include
- tests/cli/test_build.py::test_build_src_package_by_include
- tests/cli/test_build.py::test_build_with_config_settings
- tests/cli/test_build.py::test_cli_build_with_config_settings
- tests/cli/test_build.py::test_build_ignoring_pip_environment
- tests/cli/test_others.py::test_show_self_package
- tests/cli/test_publish.py::test_publish_and_build_in_one_run
- "tests/cli/test_hooks.py::test_hooks[build]"
- "tests/cli/test_hooks.py::test_hooks[publish]"
- "tests/cli/test_hooks.py::test_skip_option_from_signal[build-pre_build]"
- "tests/cli/test_hooks.py::test_skip_option_from_signal[build-post_build]"
- "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-pre_publish]"
- "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-pre_build]"
- "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-post_build]"
- "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-post_publish]"
- "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:all-build]"
- "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:all-publish]"
- "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:pre,:post-build]"
- "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:pre,:post-publish]"
- "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[pre-build]"
- "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[pre-publish]"
- "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[post-build]"
- "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[post-publish]"
- "tests/cli/test_venv.py::test_conda_backend_create[True]"
- "tests/cli/test_venv.py::test_conda_backend_create[False]"
- # hangs on interactive keyring prompts
- tests/cli/test_config.py::test_repository_overwrite_default
- tests/cli/test_config.py::test_hide_password_in_output_repository
- tests/cli/test_config.py::test_hide_password_in_output_pypi
- # junk output, sigh
- tests/cli/test_others.py::test_info_command_json
- # why does it try to use python 2.7?!
- tests/cli/test_run.py::test_import_another_sitecustomize
- # fails in tinderbox (bug #928964)
- tests/test_project.py::test_project_packages_path
- )
- [[ ${EPYTHON} != python3.10 ]] && EPYTEST_DESELECT+=(
- # test seems hardcoded to 3.10
- tests/test_project.py::test_project_packages_path
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -m "not network and not integration and not path" \
- -p pytest_mock
-}
diff --git a/dev-python/pdm/pdm-2.14.0.ebuild b/dev-python/pdm/pdm-2.14.0.ebuild
deleted file mode 100644
index 89154bdbedff..000000000000
--- a/dev-python/pdm/pdm-2.14.0.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=pdm-backend
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python package and dependency manager supporting the latest PEP standards"
-HOMEPAGE="
- https://pdm-project.org/
- https://github.com/pdm-project/pdm/
- https://pypi.org/project/pdm/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/blinker[${PYTHON_USEDEP}]
- >=dev-python/dep-logic-0.2.0[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/platformdirs[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- dev-python/truststore[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-python/msgpack[${PYTHON_USEDEP}]
- dev-python/httpx[${PYTHON_USEDEP}]
- dev-python/filelock[${PYTHON_USEDEP}]
- dev-python/hishel[${PYTHON_USEDEP}]
- dev-python/pbs-installer[${PYTHON_USEDEP}]
- dev-python/pyproject-hooks[${PYTHON_USEDEP}]
- >=dev-python/unearth-0.15.0[${PYTHON_USEDEP}]
- <dev-python/findpython-1[${PYTHON_USEDEP}]
- >=dev-python/findpython-0.6.0[${PYTHON_USEDEP}]
- dev-python/tomlkit[${PYTHON_USEDEP}]
- dev-python/shellingham[${PYTHON_USEDEP}]
- dev-python/python-dotenv[${PYTHON_USEDEP}]
- >=dev-python/resolvelib-1.0.1[${PYTHON_USEDEP}]
- dev-python/installer[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-httpserver[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Internet
- 'tests/cli/test_build.py::test_build_with_no_isolation[False]'
- tests/test_project.py::test_access_index_with_auth
- "tests/test_project.py::test_find_interpreters_with_PDM_IGNORE_ACTIVE_VENV[True]"
- tests/cli/test_others.py::test_build_distributions
- 'tests/models/test_candidates.py::test_expand_project_root_in_url[demo @ file:///${PROJECT_ROOT}/tests/fixtures/artifacts/demo-0.0.1.tar.gz]'
- 'tests/models/test_candidates.py::test_expand_project_root_in_url[-e file:///${PROJECT_ROOT}/tests/fixtures/projects/demo-#-with-hash#egg=demo]'
- tests/models/test_candidates.py::test_find_candidates_from_find_links
- tests/cli/test_build.py::test_build_single_module
- tests/cli/test_build.py::test_build_single_module_with_readme
- tests/cli/test_build.py::test_build_package
- tests/cli/test_build.py::test_build_src_package
- tests/cli/test_build.py::test_build_package_include
- tests/cli/test_build.py::test_build_src_package_by_include
- tests/cli/test_build.py::test_build_with_config_settings
- tests/cli/test_build.py::test_cli_build_with_config_settings
- tests/cli/test_build.py::test_build_ignoring_pip_environment
- tests/cli/test_others.py::test_show_self_package
- tests/cli/test_publish.py::test_publish_and_build_in_one_run
- "tests/cli/test_hooks.py::test_hooks[build]"
- "tests/cli/test_hooks.py::test_hooks[publish]"
- "tests/cli/test_hooks.py::test_skip_option_from_signal[build-pre_build]"
- "tests/cli/test_hooks.py::test_skip_option_from_signal[build-post_build]"
- "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-pre_publish]"
- "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-pre_build]"
- "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-post_build]"
- "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-post_publish]"
- "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:all-build]"
- "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:all-publish]"
- "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:pre,:post-build]"
- "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:pre,:post-publish]"
- "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[pre-build]"
- "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[pre-publish]"
- "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[post-build]"
- "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[post-publish]"
- "tests/cli/test_venv.py::test_conda_backend_create[True]"
- "tests/cli/test_venv.py::test_conda_backend_create[False]"
- tests/cli/test_lock.py::test_lock_all_with_excluded_groups
- # hangs on interactive keyring prompts
- tests/cli/test_config.py::test_repository_overwrite_default
- tests/cli/test_config.py::test_hide_password_in_output_repository
- tests/cli/test_config.py::test_hide_password_in_output_pypi
- # junk output, sigh
- tests/cli/test_others.py::test_info_command_json
- # why does it try to use python 2.7?!
- tests/cli/test_run.py::test_import_another_sitecustomize
- # fails in tinderbox (bug #928964)
- tests/test_project.py::test_project_packages_path
- )
- [[ ${EPYTHON} != python3.10 ]] && EPYTEST_DESELECT+=(
- # test seems hardcoded to 3.10
- tests/test_project.py::test_project_packages_path
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -m "not network and not integration and not path" \
- -p pytest_mock
-}