summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/qtconsole/Manifest1
-rw-r--r--dev-python/qtconsole/qtconsole-5.4.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/qtconsole/Manifest b/dev-python/qtconsole/Manifest
index 218b08518f66..f368b3c7793d 100644
--- a/dev-python/qtconsole/Manifest
+++ b/dev-python/qtconsole/Manifest
@@ -1 +1,2 @@
DIST qtconsole-5.4.0.tar.gz 431119 BLAKE2B 48348b400a9b594bd028d3905719f2d67f6c9281df99863f3d0d87cf83162c91ede3e65529a8efd3bff62ad3ea343cc4ee7ea028913cd5bf7e48d0c493930445 SHA512 c25a381d8494c64d63e379c1dd5a44c1945e773b87b9a27f8494905e7eca24c6381ec5b9792d9a57ac41b14137ce238795a5ff8d83d1b6ddaa62603e7d9ab165
+DIST qtconsole-5.4.1.tar.gz 436651 BLAKE2B 111aeacd324c9cec736f43468ebbf653047018fcd97602f82325dd7f3a92b25666615ac52a58730693d69841ddf18fd83d3468f778d7805713c07047235c83a9 SHA512 98ebb91cd30f1e046429615ef88bbcc047e4673145883b15d60b30c66d0115352b23f39c1109ddfd545e40bd261bc76070a249dbfe2e1751f7c2bf7a7e5d49f3
diff --git a/dev-python/qtconsole/qtconsole-5.4.1.ebuild b/dev-python/qtconsole/qtconsole-5.4.1.ebuild
new file mode 100644
index 000000000000..66ccc4b59413
--- /dev/null
+++ b/dev-python/qtconsole/qtconsole-5.4.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Qt-based console for Jupyter with support for rich media output"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/qtconsole/
+ https://pypi.org/project/qtconsole/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~x86"
+
+RDEPEND="
+ >=dev-python/ipykernel-4.1[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-4.1.1[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-17.1[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.2.2_p1[${PYTHON_USEDEP}]
+ >=dev-python/QtPy-2.0.1[${PYTHON_USEDEP},gui,printsupport,svg]
+"
+# The test suite tests both against pyqt5 *and* pyside2
+BDEPEND="
+ test? (
+ dev-python/QtPy[pyqt5,pyside2,${PYTHON_USEDEP},svg,testlib]
+ )
+"
+# required by the tests that are removed:
+# dev-python/flaky[${PYTHON_USEDEP}]
+# dev-python/pytest-qt[${PYTHON_USEDEP}]
+
+PDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs/source dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ # TODO: these tests require virtx; however, running under virtx
+ # causes pytest to segv on exit (even though tests pass)
+ EPYTEST_IGNORE=(
+ qtconsole/tests/test_00_console_widget.py
+ qtconsole/tests/test_jupyter_widget.py
+ )
+ epytest
+}