summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sentry-sdk/Manifest2
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.44.1.ebuild155
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-2.0.0.ebuild160
3 files changed, 0 insertions, 317 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index 25daeb35f51a..7bf1d1be4ef2 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,4 +1,2 @@
-DIST sentry-python-1.44.1.gh.tar.gz 472129 BLAKE2B ae98f7c6292ed3d95e4c33221154b065d6348c2e34efd4b4b10f083ff9082765594f39a1b0adf0df945ba7948e2b0d0d31cf2fb3987d1f65e1bd0e582be7a76b SHA512 c9de3538cdf2ccce2b6775ff57308f122d1e7f5db5036db78ec8b85a423edfbacb806080b4ededba42bc33e419b5fc71cc011bdbcf542e4aa9be1978a0129bc8
DIST sentry-python-1.45.0.gh.tar.gz 475425 BLAKE2B 8dc46154dfc1c7c9104a706be032b5269d407dee6845da252f1c603ea4f9486d02d1d3c6bec314064b821dee31b503d07a9c17935ca1f4dd6cc4d7b9c3165094 SHA512 dad23a3f6a8e6ef5fe78e1d38a61977d8974edf306d5688537f331801d8fa0f60743d18cc3dadf6e9a9666c55a01c98b9ff8d8808ece7d8f95ee68a69b6cb9be
-DIST sentry-python-2.0.0.gh.tar.gz 484223 BLAKE2B 3630ed4585ce6088d648a28b3606e945de0e230ed4a611fc1b8954e7a05f8a3e3f80ae7110c64a54ae81569fb48a0ef3ed856f8dfeec441454238157016475d4 SHA512 a97ef336e54c2e28ae4e9ff4dc921fc892bb4567c2a926c6ec5d1c838417bb8c3293576ca450bc7f08721ebe9ce37bd45e4752b6223a76a3724f2b8912426fb4
DIST sentry-python-2.0.1.gh.tar.gz 486632 BLAKE2B ace9891068050d988b3c16622f6937486f733caaf3de864ed973ea156e1e06e44f2d73764d01d5943a9347044c3c880bb9cf00229f2a36f2730aad9ef55660d0 SHA512 c62447a990ead1bebee89cd16d7a9d7a3798c48af53fba2cf5cece47c9bf5971fa1cd2b028b9fe8f7d9996cc48962ca50a61df9899b1c24a2dffced74f38e6ce
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.44.1.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.44.1.ebuild
deleted file mode 100644
index 4cdc0f653f3e..000000000000
--- a/dev-python/sentry-sdk/sentry-sdk-1.44.1.ebuild
+++ /dev/null
@@ -1,155 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{11..12} )
-
-inherit distutils-r1
-
-MY_P=sentry-python-${PV}
-DESCRIPTION="Python client for Sentry"
-HOMEPAGE="
- https://sentry.io/
- https://github.com/getsentry/sentry-python/
- https://pypi.org/project/sentry-sdk/
-"
-SRC_URI="
- https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~riscv ~sparc x86"
-
-RDEPEND="
- dev-python/urllib3[${PYTHON_USEDEP}]
- dev-python/certifi[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/asttokens[${PYTHON_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
- dev-python/executing[${PYTHON_USEDEP}]
- dev-python/fakeredis[${PYTHON_USEDEP}]
- dev-python/flask-login[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/pyrsistent[${PYTHON_USEDEP}]
- <dev-python/pytest-8[${PYTHON_USEDEP}]
- dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
- dev-python/pytest-django[${PYTHON_USEDEP}]
- dev-python/pytest-forked[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/python-socks[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
- dev-python/zope-event[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}/sentry-sdk-1.21.0-ignore-warnings.patch"
-)
-
-python_test() {
- local EPYTEST_IGNORE=(
- # tests require Internet access
- tests/integrations/httpx/test_httpx.py
- tests/integrations/requests/test_requests.py
- tests/integrations/stdlib/test_httplib.py
- tests/integrations/flask/test_flask.py
- tests/integrations/django/test_basic.py
- tests/integrations/socket/test_socket.py
- # wtf is it supposed to do?!
- tests/integrations/gcp/test_gcp.py
- # broken by rq-1.10.1 (optional dep)
- tests/integrations/rq/test_rq.py
- # fastapi is not packaged
- tests/integrations/asgi/test_fastapi.py
- # TODO
- tests/integrations/bottle
- # TODO: causes breakage in other tests
- tests/integrations/starlette
- # TODO
- tests/integrations/tornado
- # requires mockupdb
- tests/integrations/pymongo
- # requires AWS access
- tests/integrations/aws_lambda
- # requires quart_auth
- tests/integrations/quart
- # TODO: require opentelemetry (with py3.10)
- tests/integrations/opentelemetry
- )
-
- local EPYTEST_DESELECT=(
- # hangs
- 'tests/test_transport.py::test_transport_works'
- # TODO
- 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
- tests/test_client.py::test_databag_depth_stripping
- tests/test_client.py::test_databag_string_stripping
- tests/test_client.py::test_databag_breadth_stripping
- tests/integrations/asgi/test_asgi.py::test_auto_session_tracking_with_aggregates
- tests/integrations/asgi/test_asgi.py::test_websocket
- tests/integrations/aiohttp/test_aiohttp.py::test_transaction_style
- tests/integrations/aiohttp/test_aiohttp.py::test_traces_sampler_gets_request_object_in_sampling_context
- tests/integrations/django/test_data_scrubbing.py::test_scrub_django_custom_session_cookies_filtered
- # incompatible version?
- tests/integrations/falcon/test_falcon.py
- tests/integrations/sqlalchemy/test_sqlalchemy.py::test_large_event_not_truncated
- tests/integrations/django/test_data_scrubbing.py::test_scrub_django_session_cookies_{filtered,removed}
- # test_circular_references: apparently fragile
- 'tests/integrations/threading/test_threading.py::test_circular_references'
- # test for new feature, fails with IndexError
- tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
- # TODO
- tests/integrations/wsgi/test_wsgi.py::test_auto_session_tracking_with_aggregates
- tests/integrations/wsgi/test_wsgi.py::test_profile_sent_when_profiling_enabled
- tests/test_profiler.py::test_sample_buffer
- tests/test_profiler.py::test_thread_scheduler_takes_first_samples
- tests/test_profiler.py::test_thread_scheduler_takes_more_samples
- tests/test_profiler.py::test_thread_scheduler_single_background_thread
- # broken with py3.11, *shrug*
- tests/test_profiler.py::test_extract_stack_with_max_depth
- # TODO
- tests/integrations/sqlalchemy/test_sqlalchemy.py::test_long_sql_query_preserved
- tests/integrations/sqlalchemy/test_sqlalchemy.py::test_engine_name_not_string
- tests/test_scrubber.py::test_breadcrumb_extra_scrubbing
- tests/test_scrubber.py::test_span_data_scrubbing
- # this is not even funny
- tests/test_utils.py::test_installed_modules
- # flaky hypothesis stuff
- tests/test_serializer.py::test_bytes_serialization_repr_many
- # TODO
- tests/integrations/aiohttp/test_aiohttp.py::test_basic
- tests/tracing/test_decorator_py3.py::test_trace_decorator_{,a}sync_py3
- # crashes Python
- tests/integrations/grpc/test_grpc_aio.py
- # hangs
- tests/integrations/threading/test_threading.py::test_propagates_threadpool_hub
- # TODO
- tests/test_utils.py::test_default_release
- tests/integrations/sqlalchemy/test_sqlalchemy.py::test_orm_queries
- tests/integrations/sqlalchemy/test_sqlalchemy.py::test_transactions
- tests/integrations/sqlalchemy/test_sqlalchemy.py::test_query_source
- tests/integrations/stdlib/test_subprocess.py::test_subprocess_basic
- tests/integrations/threading/test_threading.py
- tests/integrations/wsgi/test_wsgi.py
- 'tests/utils/test_contextvars.py::test_leaks[threads]'
- # skipped without gevent but breaks stuff via broken teardown?
- tests/test_metrics.py::test_no_metrics_with_gevent
- # TODO
- tests/utils/test_contextvars.py::test_leaks
- # broken teardown?
- tests/test_client.py::test_uwsgi_warnings
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p asyncio -p aiohttp -p pytest_forked
-}
diff --git a/dev-python/sentry-sdk/sentry-sdk-2.0.0.ebuild b/dev-python/sentry-sdk/sentry-sdk-2.0.0.ebuild
deleted file mode 100644
index 714519a746bd..000000000000
--- a/dev-python/sentry-sdk/sentry-sdk-2.0.0.ebuild
+++ /dev/null
@@ -1,160 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{11..12} )
-
-inherit distutils-r1
-
-MY_P=sentry-python-${PV}
-DESCRIPTION="Python client for Sentry"
-HOMEPAGE="
- https://sentry.io/
- https://github.com/getsentry/sentry-python/
- https://pypi.org/project/sentry-sdk/
-"
-SRC_URI="
- https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
-
-RDEPEND="
- dev-python/urllib3[${PYTHON_USEDEP}]
- dev-python/certifi[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/asttokens[${PYTHON_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
- dev-python/executing[${PYTHON_USEDEP}]
- dev-python/fakeredis[${PYTHON_USEDEP}]
- dev-python/flask-login[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/pyrsistent[${PYTHON_USEDEP}]
- <dev-python/pytest-8[${PYTHON_USEDEP}]
- dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
- dev-python/pytest-django[${PYTHON_USEDEP}]
- dev-python/pytest-forked[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/python-socks[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
- dev-python/zope-event[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}/sentry-sdk-1.21.0-ignore-warnings.patch"
-)
-
-python_test() {
- local EPYTEST_IGNORE=(
- # tests require Internet access
- tests/integrations/httpx/test_httpx.py
- tests/integrations/requests/test_requests.py
- tests/integrations/stdlib/test_httplib.py
- tests/integrations/flask/test_flask.py
- tests/integrations/django/test_basic.py
- tests/integrations/socket/test_socket.py
- # wtf is it supposed to do?!
- tests/integrations/gcp/test_gcp.py
- # broken by rq-1.10.1 (optional dep)
- tests/integrations/rq/test_rq.py
- # fastapi is not packaged
- tests/integrations/asgi/test_fastapi.py
- # TODO
- tests/integrations/bottle
- # TODO: causes breakage in other tests
- tests/integrations/starlette
- # TODO
- tests/integrations/tornado
- # requires mockupdb
- tests/integrations/pymongo
- # requires AWS access
- tests/integrations/aws_lambda
- # requires quart_auth
- tests/integrations/quart
- # TODO: require opentelemetry (with py3.10)
- tests/integrations/opentelemetry
- )
-
- local EPYTEST_DESELECT=(
- # hangs
- 'tests/test_transport.py::test_transport_works'
- # TODO
- 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
- tests/test_client.py::test_databag_depth_stripping
- tests/test_client.py::test_databag_string_stripping
- tests/test_client.py::test_databag_breadth_stripping
- tests/integrations/asgi/test_asgi.py::test_auto_session_tracking_with_aggregates
- tests/integrations/asgi/test_asgi.py::test_websocket
- tests/integrations/aiohttp/test_aiohttp.py::test_transaction_style
- tests/integrations/aiohttp/test_aiohttp.py::test_traces_sampler_gets_request_object_in_sampling_context
- tests/integrations/django/test_data_scrubbing.py::test_scrub_django_custom_session_cookies_filtered
- # incompatible version?
- tests/integrations/falcon/test_falcon.py
- tests/integrations/sqlalchemy/test_sqlalchemy.py::test_large_event_not_truncated
- tests/integrations/django/test_data_scrubbing.py::test_scrub_django_session_cookies_{filtered,removed}
- # test_circular_references: apparently fragile
- 'tests/integrations/threading/test_threading.py::test_circular_references'
- # test for new feature, fails with IndexError
- tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
- # TODO
- tests/integrations/wsgi/test_wsgi.py::test_auto_session_tracking_with_aggregates
- tests/integrations/wsgi/test_wsgi.py::test_profile_sent_when_profiling_enabled
- tests/test_profiler.py::test_sample_buffer
- tests/test_profiler.py::test_thread_scheduler_takes_first_samples
- tests/test_profiler.py::test_thread_scheduler_takes_more_samples
- tests/test_profiler.py::test_thread_scheduler_single_background_thread
- # broken with py3.11, *shrug*
- tests/test_profiler.py::test_extract_stack_with_max_depth
- # TODO
- tests/integrations/sqlalchemy/test_sqlalchemy.py::test_long_sql_query_preserved
- tests/integrations/sqlalchemy/test_sqlalchemy.py::test_engine_name_not_string
- tests/test_scrubber.py::test_breadcrumb_extra_scrubbing
- tests/test_scrubber.py::test_span_data_scrubbing
- # this is not even funny
- tests/test_utils.py::test_installed_modules
- # flaky hypothesis stuff
- tests/test_serializer.py::test_bytes_serialization_repr_many
- # TODO
- tests/integrations/aiohttp/test_aiohttp.py::test_basic
- tests/tracing/test_decorator_py3.py::test_trace_decorator_{,a}sync_py3
- # crashes Python
- tests/integrations/grpc/test_grpc_aio.py
- # hangs
- tests/integrations/threading/test_threading.py::test_propagates_threadpool_hub
- # TODO
- tests/test_utils.py::test_default_release
- tests/integrations/sqlalchemy/test_sqlalchemy.py::test_orm_queries
- tests/integrations/sqlalchemy/test_sqlalchemy.py::test_transactions
- tests/integrations/sqlalchemy/test_sqlalchemy.py::test_query_source
- tests/integrations/stdlib/test_subprocess.py::test_subprocess_basic
- tests/integrations/threading/test_threading.py
- tests/integrations/wsgi/test_wsgi.py
- 'tests/utils/test_contextvars.py::test_leaks[threads]'
- # skipped without gevent but breaks stuff via broken teardown?
- tests/test_metrics.py::test_no_metrics_with_gevent
- # TODO
- tests/utils/test_contextvars.py::test_leaks
- # broken teardown?
- tests/test_client.py::test_uwsgi_warnings
- # too many dependencies installed, sigh
- tests/test_new_scopes_compat_event.py
- # TODO
- tests/tracing/test_sampling.py::test_records_lost_event_only_if_traces_sample_rate_enabled
- tests/tracing/test_sampling.py::test_records_lost_event_only_if_traces_sampler_enabled
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p asyncio -p aiohttp -p pytest_forked
-}