summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pydbus/Manifest1
-rw-r--r--dev-python/pydbus/metadata.xml1
-rw-r--r--dev-python/pydbus/pydbus-0.6.0-r1.ebuild26
3 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pydbus/Manifest b/dev-python/pydbus/Manifest
index b9f58f6611ea..8ceab61cc6f1 100644
--- a/dev-python/pydbus/Manifest
+++ b/dev-python/pydbus/Manifest
@@ -1 +1,2 @@
+DIST pydbus-0.6.0.gh.tar.gz 2083046 BLAKE2B 65b50b272b004b30411ff396a9c50d8602485f281100467e2c75ed300cdb0a83532a354a62ef1a8e7ee38a41af243ea7de7a5e80232cfc7c79540e8ed71741c6 SHA512 65ac490dd44ad0aba0b3ea5c58cf6a99bd9de0ce86c6f03b9696335fb2d3f63df0e2e23a022d31d0185f7b8307bcc0f6e230efecc31199fc177f9a8a25929ad7
DIST pydbus-0.6.0.tar.gz 2083046 BLAKE2B 65b50b272b004b30411ff396a9c50d8602485f281100467e2c75ed300cdb0a83532a354a62ef1a8e7ee38a41af243ea7de7a5e80232cfc7c79540e8ed71741c6 SHA512 65ac490dd44ad0aba0b3ea5c58cf6a99bd9de0ce86c6f03b9696335fb2d3f63df0e2e23a022d31d0185f7b8307bcc0f6e230efecc31199fc177f9a8a25929ad7
diff --git a/dev-python/pydbus/metadata.xml b/dev-python/pydbus/metadata.xml
index ed8e75d331f4..a30c89b5993c 100644
--- a/dev-python/pydbus/metadata.xml
+++ b/dev-python/pydbus/metadata.xml
@@ -9,5 +9,6 @@
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">pydbus</remote-id>
+ <remote-id type="github">LEW21/pydbus</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/pydbus/pydbus-0.6.0-r1.ebuild b/dev-python/pydbus/pydbus-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..deb7400487d8
--- /dev/null
+++ b/dev-python/pydbus/pydbus-0.6.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Pythonic DBus library"
+HOMEPAGE="https://github.com/LEW21/pydbus"
+SRC_URI="https://github.com/LEW21/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ sys-apps/dbus
+"
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/install/$(python_get_sitedir)" \
+ sh tests/run.sh "${PYTHON}" || die
+}