summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dparse/Manifest1
-rw-r--r--dev-python/dparse/dparse-0.6.4_beta0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/dparse/Manifest b/dev-python/dparse/Manifest
index f44e340fd614..5c255e1dfcf9 100644
--- a/dev-python/dparse/Manifest
+++ b/dev-python/dparse/Manifest
@@ -1 +1,2 @@
DIST dparse-0.6.3.tar.gz 20316 BLAKE2B 6da05ddd01b059f8c7473be99f80d0b870c61f5417b3957a7ba55077e2e4757c0a7438b64abde042ea9d4d4a8faa0024752e735c02136f8274ba3ad120324a02 SHA512 b73623fee7add7bf7d5f453c96f602a28ceca8552bba14f938ad3102da38f23e9a93469cf716beeb0a2f2a578562e3ab843c1e86b7615c315b100c0c32108a7b
+DIST dparse-0.6.4b0.tar.gz 25761 BLAKE2B c2f430e9a59ca3747d00151aa5e5afdc51ad42dccafb2d5c95c4a62e405109bab6bba9de39a62703ef6f1846081cac9cb1e2bcc3986690ca6dc2f21220ffedd6 SHA512 f0cf9f07bca93388e85d0aa5bb8359cdaf276c5abf146f8469fe7b32a2ca0614452bcb3a48c55da4421964062fc0baf538386dce8f5e2a70b618533c870791ac
diff --git a/dev-python/dparse/dparse-0.6.4_beta0.ebuild b/dev-python/dparse/dparse-0.6.4_beta0.ebuild
new file mode 100644
index 000000000000..d595a0a169d5
--- /dev/null
+++ b/dev-python/dparse/dparse-0.6.4_beta0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A parser for Python dependency files"
+HOMEPAGE="
+ https://github.com/pyupio/dparse
+ https://pypi.org/project/dparse/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+BDEPEND="
+ test? (
+ dev-python/pipenv[${PYTHON_USEDEP}]
+ )
+"
+
+# Break circular dependency
+PDEPEND="
+ dev-python/pipenv[${PYTHON_USEDEP}]
+"