summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/numexpr/Manifest1
-rw-r--r--dev-python/numexpr/numexpr-2.7.2_p1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/numexpr/Manifest b/dev-python/numexpr/Manifest
index bb55c8487ed5..848f084a426e 100644
--- a/dev-python/numexpr/Manifest
+++ b/dev-python/numexpr/Manifest
@@ -1 +1,2 @@
DIST numexpr-2.7.2.gh.tar.gz 118982 BLAKE2B b032f00c36ffadb88cf9a4cd6323137b920bce48ec73f88f006d3186f9a8c1d75a11ceb6bd32f412cba5c10cbe3cb518cdbdb19ef022100fcc408fc82ede9881 SHA512 41946df6d642e226b4a38b11d5db67ef91d63d56b33d3b52f09377c022d236ea4e9a5aaaf380737d18405ee25109260ae60f79d0c9465b95de14465f41c40075
+DIST numexpr-2.7.2.r1.gh.tar.gz 119099 BLAKE2B d424dd89761ecdad3e5a35a5c8b41f089c6eb7c9ca10a4309fb489bb7ab60c0b77863c1675583014265c057e27f3b9584a35e0ac6232044ed5f8b8c32fd330d6 SHA512 d786aeb3597a6b2196e92f364934a0bbc518c7973252c38f1e93c317d55220270b5d61320d7a465c87da979ec68e988b25182d527e0e96aa3a898f20a6997802
diff --git a/dev-python/numexpr/numexpr-2.7.2_p1.ebuild b/dev-python/numexpr/numexpr-2.7.2_p1.ebuild
new file mode 100644
index 000000000000..baa034dc390b
--- /dev/null
+++ b/dev-python/numexpr/numexpr-2.7.2_p1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
+HOMEPAGE="https://github.com/pydata/numexpr"
+SRC_URI="
+ https://github.com/pydata/numexpr/archive/v${PV%_p*}.tar.gz
+ -> ${P/_p/.r}.gh.tar.gz"
+S=${WORKDIR}/${P%_p*}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="mkl"
+
+RDEPEND="
+ >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
+ mkl? ( sci-libs/mkl )
+"
+
+python_prepare_all() {
+ # TODO: mkl can be used but it fails for me
+ # only works with mkl in tree. newer mkl will use pkgconfig
+ if use mkl; then
+ use amd64 && local ext="_lp64"
+ cat > site.cfg <<- _EOF_ || die
+ [mkl]
+ library_dirs = ${MKLROOT}/lib/em64t
+ include_dirs = ${MKLROOT}/include
+ mkl_libs = mkl_solver${ext}, mkl_intel${ext}, \
+ mkl_intel_thread, mkl_core, iomp5
+ _EOF_
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pushd "${BUILD_DIR}"/lib >/dev/null || die
+ "${EPYTHON}" \
+ -c "import sys,numexpr; sys.exit(0 if numexpr.test().wasSuccessful() else 1)" \
+ || die
+ pushd >/dev/null || die
+}