summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-4.50.8.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 52226eb6ceef..fcab5cd18098 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -5,3 +5,4 @@ DIST hypothesis-python-4.44.2.tar.gz 3240386 BLAKE2B 3fe3295ba1f7401e1fb74af894d
DIST hypothesis-python-4.47.5.tar.gz 6805022 BLAKE2B 737a558c794f3ac428bef4b38858d47fddba613ce37eb9a9554afa3c189776e9172965dd31f8497747ac13b2ab1d34ee6de8671646972e71b82c5260db489b9a SHA512 9b6920181dca75b9e551ae5e598101f35cfc26e9e3a1b20cab652c151bc6355413d0c9602d3242fb23f808ab00335793009df938d55ee19a6af1ce2a8b085e3c
DIST hypothesis-python-4.50.3.tar.gz 6812208 BLAKE2B 2c5102e3fe62cf405f4e9216e516d9cf0a1fb3f138cb6578a75187bc8d5e1736eba9e88c88521ec9439e91f520d3077ea7bc116c9f059331534791e3ce969b31 SHA512 fbf4b5ca052ca6e3fc647b2b48c3f91d6aa6eba630abfe44c545d1d618834875ed8fe87b49daccc0780478bc259b790178640072e509e8dacbac9bc4b20d99fa
DIST hypothesis-python-4.50.6.tar.gz 6812382 BLAKE2B e38b2cb455dae3f68d2e643957fe1f09156005fbb9017ca0d9e4123582794ab551c6ba0cb3648556fb4d592d429cbb68023b0f42cc97d9bb6e458ad8fe9ed4ef SHA512 6fad54c323373cd868e3d3a87470659fcb20d1d462cf3c034b23938b91d2c75802e4a69164e19e0dd60b850dfe450f12228f6c078db7ffa9926710bd35f683ae
+DIST hypothesis-python-4.50.8.tar.gz 6814518 BLAKE2B f2c39cae3708fe88d1854cda97633ba420c32fda38093bb852ef45929762cade0f7f0d1ef696ff96f7ebe7460e8bf53f63de9c959bbbd9e8ec162196d307aac0 SHA512 8c77439fd029e2380afbc059d2edf977414997ba81ecdfde14dfe9dbe9515a92e701751d13879c6b879271f817e01926c2dc66945ae76eb141818da1775bc545
diff --git a/dev-python/hypothesis/hypothesis-4.50.8.ebuild b/dev-python/hypothesis/hypothesis-4.50.8.ebuild
new file mode 100644
index 000000000000..3def9e851218
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-4.50.8.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' pypy)
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.3[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+src_prepare() {
+ # avoid pytest-xdist dep for one test
+ sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+ tests/pytest/test_statistics.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local pyver=$(python_is_python3 && echo 3 || echo 2)
+ pytest -vv tests/cover tests/pytest tests/py${pyver} ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}