summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.121.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index a65918522d1c..9a19f8c807f1 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.26.114.gh.tar.gz 637000 BLAKE2B 06f74ac214f4c2161ebe464e1c8fc42c74c
DIST boto3-1.26.118.gh.tar.gz 639685 BLAKE2B 45ba98f4a1b72c45caef8f04e1b5f5fe5a35e8e8fd4248f77889f780e9909caebb3d5715d0de5bb5f25ee353352e0860745643ddee503ffb8d1f99c8e42658c6 SHA512 cd62f9a9b087db2b2805e672c9e938da230390980d2163e06549b03cc3f009dbdad1e80205c392c24af5c4d98cefe3f2354244e9e9d20d706a8c69e34caa07ea
DIST boto3-1.26.119.gh.tar.gz 640125 BLAKE2B c2a1e954c09b4322d6d369205a11013e5b84786cf3c1193ecb80792f215eeb9c6d96fd56c99fd2845c25bc8ab1a99a8f075dad142be79d2e5eb57f0bd20a7942 SHA512 21e3f5750d91de981cbfd0d7cd4dd6a7bacae56391544889ab683e686c2cdb843e1c67d67f62dfe1465e46eb59efe503eb4d626241c2372988bf40d5cfc66f23
DIST boto3-1.26.120.gh.tar.gz 639240 BLAKE2B 835fb02e44ccdb7d2b7aa2604d3605db9efa454ca455a52e67861b218523acc6737260c9d860639195a4d4181f4be9eaab0acf2b80e33416274cd99d65a74c80 SHA512 426aed9ba45cdc0d584fa0a571104b6f17dfb32c78da17a85b0dbe9f6c77c84a70533b4affa4728758a9d3a339d5d72b54186eb08dc2bd319b3d1e75374adbd0
+DIST boto3-1.26.121.gh.tar.gz 639340 BLAKE2B 3f8224aa4659d6b0581ce1b6f48367f15ba6d69520462251c5ee88922afa8af661471ad5058ea54bf75871081dce5feec027050f09222f63168362e3db05dcd1 SHA512 d0e4ada1ddd1198d1d964cb2c4a629c72f7931d35b27d8a0c71c04d605b750b725e31b3713047df817b3b12ad090e33e8b3ece650e0a87041261df5534ce4a90
diff --git a/dev-python/boto3/boto3-1.26.121.ebuild b/dev-python/boto3/boto3-1.26.121.ebuild
new file mode 100644
index 000000000000..2a4a7643203e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.121.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}