summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/colorclass/colorclass-2.2.0-r1.ebuild23
-rw-r--r--dev-python/colorclass/files/colorclass-2.2.0-tests.patch12
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/colorclass/colorclass-2.2.0-r1.ebuild b/dev-python/colorclass/colorclass-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..edf891faaa70
--- /dev/null
+++ b/dev-python/colorclass/colorclass-2.2.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+inherit distutils-r1
+
+DESCRIPTION="Colorful worry-free console applications for multiple platforms"
+HOMEPAGE="https://pypi.org/project/colorclass/ https://github.com/Robpol86/colorclass"
+SRC_URI="https://github.com/Robpol86/colorclass/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}/colorclass-2.2.0-tests.patch"
+)
+
+distutils_enable_tests pytest
diff --git a/dev-python/colorclass/files/colorclass-2.2.0-tests.patch b/dev-python/colorclass/files/colorclass-2.2.0-tests.patch
new file mode 100644
index 000000000000..f25dd0440aa7
--- /dev/null
+++ b/dev-python/colorclass/files/colorclass-2.2.0-tests.patch
@@ -0,0 +1,12 @@
+diff --git a/tests/test_example.py b/tests/test_example.py
+index 7ee8c05..3516460 100644
+--- a/tests/test_example.py
++++ b/tests/test_example.py
+@@ -10,6 +10,7 @@ from tests.conftest import PROJECT_ROOT
+ from tests.screenshot import RunNewConsole, screenshot_until_match
+
+
++@pytest.mark.skip(reason="test fails on all platforms")
+ @pytest.mark.parametrize('colors', [True, False, None])
+ @pytest.mark.parametrize('light_bg', [True, False, None])
+ def test_piped(colors, light_bg):