summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/gpep517/Manifest1
-rw-r--r--dev-python/gpep517/gpep517-8.ebuild41
2 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/gpep517/Manifest b/dev-python/gpep517/Manifest
index 8cfae3e3b83e..1d5c068e1e5b 100644
--- a/dev-python/gpep517/Manifest
+++ b/dev-python/gpep517/Manifest
@@ -1,2 +1 @@
-DIST gpep517-8.gh.tar.gz 12858 BLAKE2B d02acc844f79495847b151449e2cbc3378122eaf4ae97957f4a3a447cac0adcb9d7fa065e79c52e3901bead5c2112ad140e16689e56fa1a09b8b68078c41210c SHA512 40a405e0d4700a62c7e1aaa8b2679849e18ad5d76b4b733c18632c549c4038ba8594fb48a86ba612b162ef9f433cad90fa3ee7fc92f45b13b88fed7e4cca16b0
DIST gpep517-9.gh.tar.gz 15227 BLAKE2B b3c2b3e4452a7e27725eea0a6a0b1b362e1ea6bbdae44d99a2992c9edac80a4fdbf2ed75a231004534039c6d6f6db54d9fdbdc7c2c7044bb85cbc3f88484be41 SHA512 94cd1ddb1de7844504906b056ec5eb9d0e80da4f6bde6b561075c754a78a97e6db6025a793592c9498fad54ebab48c5497b29268c40d6992f5ef793a698b9da1
diff --git a/dev-python/gpep517/gpep517-8.ebuild b/dev-python/gpep517/gpep517-8.ebuild
deleted file mode 100644
index 899810bac85d..000000000000
--- a/dev-python/gpep517/gpep517-8.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_PEP517=no
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="A backend script to aid installing Python packages in Gentoo"
-HOMEPAGE="
- https://pypi.org/project/gpep517/
- https://github.com/mgorny/gpep517/
-"
-SRC_URI="
- https://github.com/mgorny/gpep517/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-RDEPEND="
- >=dev-python/installer-0.5.0[${PYTHON_USEDEP}]
- >=dev-python/tomli-1.2.3[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_install() {
- python_domodule gpep517
- python_newscript - gpep517 <<-EOF
- #!${EPREFIX}/usr/bin/python
- import sys
- from gpep517.__main__ import main
- sys.exit(main())
- EOF
-}