summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinxcontrib-htmlhelp/Manifest1
-rw-r--r--dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.4.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-htmlhelp/Manifest b/dev-python/sphinxcontrib-htmlhelp/Manifest
index d53d56ff002d..14280748ad37 100644
--- a/dev-python/sphinxcontrib-htmlhelp/Manifest
+++ b/dev-python/sphinxcontrib-htmlhelp/Manifest
@@ -1,2 +1,3 @@
DIST sphinxcontrib-htmlhelp-2.0.1.tar.gz 27967 BLAKE2B 922921a52c421bde9787df6fd5107a515bb0af4f4a6a6c8b84f474b9d7b0ce9251437b8780b3464190e494555bbe6d72604e155bce98794c36c03ddbcc5c4cc7 SHA512 7957ad688d7f9d44c0413fd747147e8e261136d48ed159fef4e668dcab76c54103028102a9ed893bfadbd175b88543e0d1414b8e01a716810d44b92edfbd79e5
DIST sphinxcontrib_htmlhelp-2.0.3.tar.gz 21752 BLAKE2B c21a6b046aff388a05e8a2a3b926f1b5e3e4b280ce0f504cd799efe72470d9602ab67bca3ed7d45ad94bda395682cdc3e501a29602d70ff58e22e897155872ea SHA512 1a185c28e0a1159b51a2f93773684d6703857b25498f83aa3b8644aa87f26c7ba9b8b88ddaabe0021d0572cbbe52bffabe90d58247fb8a883d662e09cac7f1ef
+DIST sphinxcontrib_htmlhelp-2.0.4.tar.gz 21799 BLAKE2B ef5f5c26696cadc37feefda8b5343562efd45ab7685d472d820f4e391a1699993f26634269087c24971b176ef7b05e0191f90dc6b07093ca25a424bbf7a2a69d SHA512 5f1c4619b986060fb6213e23b5339b7b5d57abdb8f6034473116c9ea7c3d04cf0985115141c5325cb93bac330eb6109d2e81327f53fda78838c9ed5435469b29
diff --git a/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.4.ebuild b/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.4.ebuild
new file mode 100644
index 000000000000..1bc7cc2853dc
--- /dev/null
+++ b/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which outputs HTML help book"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-htmlhelp/
+ https://pypi.org/project/sphinxcontrib-htmlhelp/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${PDEPEND}
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest