summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-ctags3/Manifest1
-rw-r--r--dev-python/python-ctags3/python-ctags3-1.5.0-r1.ebuild40
2 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/python-ctags3/Manifest b/dev-python/python-ctags3/Manifest
index f15cc365e95b..9d0661d91699 100644
--- a/dev-python/python-ctags3/Manifest
+++ b/dev-python/python-ctags3/Manifest
@@ -1,2 +1 @@
-DIST python-ctags3-1.5.0.gh.tar.gz 63921 BLAKE2B 1d25e7bafbdf157f1051321058b39fc9347bc479a61fae637bd11ef8540a3c67e2abd101493668977f05e464a8203b8c518fd1f4433defe5cec9939a200438b2 SHA512 414774c865af51e54c53f66dc7b3cfb5a03b64ea4eb94325658c158542615dfffdd1a5933d9ae03cedf1dbac30e1810d5914fbc3d6ab41e5f708c5d3000d161e
DIST python-ctags3-1.6.0.gh.tar.gz 70311 BLAKE2B f286aad922f8220d5f0b42f2919425d836bd27e9b2a85739333295d6e681172b20d33d010821c881583a4bed29d103939cf4b7e1d67190ba52cf1e0a1ca75290 SHA512 38df28c1055b2240e5da7699a7c72bab85908c7b1a1b4db83f19350541fe49d8499a9b7400ad14c77166b459fbb30f6b2c22d65685ac5f392ececa3eeecb6f41
diff --git a/dev-python/python-ctags3/python-ctags3-1.5.0-r1.ebuild b/dev-python/python-ctags3/python-ctags3-1.5.0-r1.ebuild
deleted file mode 100644
index fea99da7b0d2..000000000000
--- a/dev-python/python-ctags3/python-ctags3-1.5.0-r1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P="python-ctags3-${PV}"
-DESCRIPTION="Exuberant Ctags indexing python bindings"
-HOMEPAGE="https://github.com/universal-ctags/python-ctags3"
-# PyPI tarballs don't contain pyx files
-SRC_URI="https://github.com/universal-ctags/python-ctags3/archive/${PV}.tar.gz -> ${MY_P}.gh.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-util/ctags:="
-BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # We currently need to let Cython regenerate this file to make Python 3.11
- # support work
- rm src/_readtags.c || die
- cython -3 src/_readtags.pyx || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # To prevent pytest from importing it and failing with:
- # ModuleNotFoundError: No module named 'ctags._readtags'
- rm -rf src/ctags || die
- epytest
-}