summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pywlroots/Manifest1
-rw-r--r--dev-python/pywlroots/pywlroots-0.16.3.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pywlroots/Manifest b/dev-python/pywlroots/Manifest
index 446dcdbf2f88..b94e8dc8a99c 100644
--- a/dev-python/pywlroots/Manifest
+++ b/dev-python/pywlroots/Manifest
@@ -1,3 +1,4 @@
DIST pywlroots-0.15.24.gh.tar.gz 85570 BLAKE2B 0c7ba0be6159152488785298028bb1feec20e2380357060a850dab417b3fb1fccb4a9e6cc6564d2b7f124bf4fc454789549267e9036b0b4559e5fcd4c6f06196 SHA512 b29b76cf18a65b2ef19d15ecf018a9ba44119d60ee61435967d17f06d5f7544d2117f2e9a81574734c71591a237b00c8584a5cc6d6adb928f39f11170f21ee94
DIST pywlroots-0.16.1.gh.tar.gz 90101 BLAKE2B 5b26b8aeacef7336353376f1ac0f230f88e50da3dca1ac726470791555edb9c486234122242ced3220b893eb6d0666cfc6519f23ed3922645549ff012ab46d04 SHA512 599210486c6461660b2c85b69726afc30c5b0d835e61ee2cf246296aaccf9d8fb1e332d7eb50a30599f155fbbd7c5c204ca1158d9a8122fcc36fbf745085902f
DIST pywlroots-0.16.2.gh.tar.gz 90372 BLAKE2B 94107199e912b53e484d0fd81f18900bb5b2283a588b09da2c078606881f1cbe8e25bec3bada32e1d0c74300374d66c95d56ff976661813730ffedaf023cb57a SHA512 314339e6b4f66f03af74fc7e69814b4e1e879da6ec624f33eb3b04e26a7a4159776f182830a3b2ff31720021386cab70cdfc16a0b2377414c94cd834fd1ca26c
+DIST pywlroots-0.16.3.gh.tar.gz 90971 BLAKE2B 67eceeb4e4724ee3c1dcc3afb21c3466a21e8a1e9b56b2adf0a7b236990f9fc69c80f7ae056d0b0f9914149ead29cdb9dd671606a7fc67b2e860bb0bccd3a19b SHA512 46a095c818eee4205115a948f5b88078815aa9a4849e2f08108d3898349772acab70a71c2f083e1a6e78c29cc612661412203d618e77f1c2d94d1387fcf6425f
diff --git a/dev-python/pywlroots/pywlroots-0.16.3.ebuild b/dev-python/pywlroots/pywlroots-0.16.3.ebuild
new file mode 100644
index 000000000000..b802883e934e
--- /dev/null
+++ b/dev-python/pywlroots/pywlroots-0.16.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python binding to the wlroots library using cffi"
+HOMEPAGE="
+ https://github.com/flacjacket/pywlroots/
+ https://pypi.org/project/pywlroots/
+"
+SRC_URI="
+ https://github.com/flacjacket/pywlroots/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+# See README for wlroots dep
+DEPEND="
+ >=dev-python/pywayland-0.4.14[${PYTHON_USEDEP}]
+ >=dev-python/xkbcommon-0.2[${PYTHON_USEDEP}]
+ =gui-libs/wlroots-$(ver_cut 1-2)*:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.15.24-no-import-version-check.patch
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf wlroots || die
+ epytest
+}