summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/webassets/Manifest1
-rw-r--r--dev-python/webassets/webassets-0.12.ebuild39
2 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/webassets/Manifest b/dev-python/webassets/Manifest
index 82e9680a8245..871a80576754 100644
--- a/dev-python/webassets/Manifest
+++ b/dev-python/webassets/Manifest
@@ -1,2 +1 @@
DIST webassets-0.12.1.tar.gz 181402 BLAKE2B 907a4184e0274a9543bda2b7c2fdfeabef346b0920d98e04abbfb3b9858ecae3c0da32b65efe8e4b52d82ab938e182e2e37f005ba25afb1d62235dcc5bc9bee7 SHA512 1e65956afc63dd4bbf43b3b7e220ec6edb8d69d817c6361de67bf8fc7a90b34d3f7e4d0bae4cc45cb3fc043802d2e5d5c8a7cc87421186000212a36605fbc26e
-DIST webassets-0.12.tar.gz 180368 BLAKE2B eb7484d724d41467a8c04c1407cba9666abc77d52b06736f489f20593deb265f30d682ce26ae8bec5f34bcd66b11d052c5ee240d9dab191e7c471c8ec62f9916 SHA512 ad95e5345f9f736389fc684c5b51bb47ad5abb3bdca03a3a4649892095d139722aaf5aa57677997fe869e751b1b82a63c3a882c58005bc6a2ab954bc479447b7
diff --git a/dev-python/webassets/webassets-0.12.ebuild b/dev-python/webassets/webassets-0.12.ebuild
deleted file mode 100644
index c33b8e317594..000000000000
--- a/dev-python/webassets/webassets-0.12.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_5 )
-
-inherit distutils-r1
-
-DESCRIPTION="Asset management for Python web development"
-HOMEPAGE="https://github.com/miracle2k/webassets"
-SRC_URI="https://github.com/miracle2k/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-# ^^ pypi tarball is missing tests
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # webassets wants /usr/bin/babel from babeljs,
- # but we have only one from openbabel
- # ... and we don't have postcss
- sed -i \
- -e 's|\(TestBabel\)|No\1|' \
- -e 's|\(TestAutoprefixer6Filter\)|No\1|' \
- tests/test_filters.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test -v || die
-}