summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dulwich/dulwich-0.21.7-r1.ebuild (renamed from dev-python/dulwich/dulwich-0.21.7.ebuild)11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-python/dulwich/dulwich-0.21.7.ebuild b/dev-python/dulwich/dulwich-0.21.7-r1.ebuild
index 5ddf377dafa2..3369252c2d5f 100644
--- a/dev-python/dulwich/dulwich-0.21.7.ebuild
+++ b/dev-python/dulwich/dulwich-0.21.7-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -34,6 +34,15 @@ BDEPEND="
distutils_enable_sphinx docs
+src_prepare() {
+ # Do not install "docs" directory into site-packages
+ # https://github.com/jelmer/dulwich/issues/1248
+ sed -i -e '/package_data/d' setup.py || die
+ rm -r *.egg-info || die
+
+ distutils-r1_src_prepare
+}
+
python_test() {
# remove interference from the tests that do stuff like user.name
unset GIT_AUTHOR_NAME GIT_AUTHOR_EMAIL GIT_AUTHOR_DATE