summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/execnet/Manifest2
-rw-r--r--dev-python/execnet/execnet-1.4.1.ebuild51
-rw-r--r--dev-python/execnet/execnet-1.5.0.ebuild51
3 files changed, 0 insertions, 104 deletions
diff --git a/dev-python/execnet/Manifest b/dev-python/execnet/Manifest
index b35040d60c57..05a58c8dbb9e 100644
--- a/dev-python/execnet/Manifest
+++ b/dev-python/execnet/Manifest
@@ -1,3 +1 @@
-DIST execnet-1.4.1.tar.gz 171041 BLAKE2B 7e51320969b0203a8ff55d69364c3fa69d747d67f5dd3a3aaeab7700192d63918bbc11ae29a1e26e466078f1ca87ea00ddcfe0f98132921bacfc95671c3ad7c7 SHA512 e8c0c32e873f8585ff4d4da3b9cbd40046479370f5653f67a98c9029d4535a619731d1b825332fe4af4dc5ebc9ab11ee879ef45df07f08943b1e1685f2255790
-DIST execnet-1.5.0.tar.gz 168497 BLAKE2B 1777f3a72cbf75e5bdef90cdda956a5d8101980f299a1bade6d6faeec52e1026a18a87c8b6b08c8d27073acedacd38473f68c6823908701816b4725edd3d9fb0 SHA512 ca2b571fafdf8f68b3cc7a04ee326e3255828d4cde28ead65d0cef325569c3a6dee09359e525152248038de65326ffc6b75c8362f53aa5c0b3f736eb596cb2d9
DIST execnet-1.7.1.tar.gz 174157 BLAKE2B 0c2f7b8918bdd5a3cd1fdc49607e571874e20bd26a4806a6ec1a11359b912ed09244afb781670ff24fbee752516d59ab2bba7f662bbcddb802e7e6efd2c544ef SHA512 375748c03f8d955bd8fca90d5c6308073c31a978fd7a604257512e0a710f899dec5db8a91d5bb5f16de9b0656e1742da9ab513827a1a065a5125bafcf1e63a70
diff --git a/dev-python/execnet/execnet-1.4.1.ebuild b/dev-python/execnet/execnet-1.4.1.ebuild
deleted file mode 100644
index 45cfc1a2ca2d..000000000000
--- a/dev-python/execnet/execnet-1.4.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Rapid multi-Python deployment"
-HOMEPAGE="http://codespeak.net/execnet/ https://pypi.org/project/execnet/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
-IUSE="doc test"
-
-RDEPEND=">=dev-python/apipkg-1.4[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-#PATCHES=( "${FILESDIR}"/1.2.0-tests.patch )
-RESTRICT="test"
-
-python_prepare_all() {
- # Remove doctest that access an i'net site
- rm doc/example/test_info.txt || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- # https://bitbucket.org/hpk42/execnet/issue/10
- unset PYTHONDONTWRITEBYTECODE
- py.test testing || die "Tests fail with ${EPYTHON}"
-
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/execnet/execnet-1.5.0.ebuild b/dev-python/execnet/execnet-1.5.0.ebuild
deleted file mode 100644
index 6c9e32d8503f..000000000000
--- a/dev-python/execnet/execnet-1.5.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Rapid multi-Python deployment"
-HOMEPAGE="http://codespeak.net/execnet/ https://pypi.org/project/execnet/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="doc test"
-
-RDEPEND=">=dev-python/apipkg-1.4[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-#PATCHES=( "${FILESDIR}"/1.2.0-tests.patch )
-RESTRICT="test"
-
-python_prepare_all() {
- # Remove doctest that access an i'net site
- rm doc/example/test_info.rst || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- # https://bitbucket.org/hpk42/execnet/issue/10
- unset PYTHONDONTWRITEBYTECODE
- py.test testing || die "Tests fail with ${EPYTHON}"
-
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
-
- distutils-r1_python_install_all
-}