summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyannotate/Manifest1
-rw-r--r--dev-python/pyannotate/metadata.xml21
-rw-r--r--dev-python/pyannotate/pyannotate-1.2.0.ebuild20
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pyannotate/Manifest b/dev-python/pyannotate/Manifest
new file mode 100644
index 000000000000..3ca425937400
--- /dev/null
+++ b/dev-python/pyannotate/Manifest
@@ -0,0 +1 @@
+DIST pyannotate-1.2.0.gh.tar.gz 46148 BLAKE2B c52c93c0d27cb23b0b0683bbd5f353ba9a45714b8a50fb3a6f5aa4e67bfe71e60bc7afbee85a021ed25a7f5a1df720dc863fc6dd92d20dee0d97af72786866cf SHA512 cd755f3061f5c4320346f0198b71e4b312378a3810c5999f1d318b7427e7c55bd1bdfc4af84880bd45faf69eabccbd2684d1c18c1f9ad0661d35a377984ca063
diff --git a/dev-python/pyannotate/metadata.xml b/dev-python/pyannotate/metadata.xml
new file mode 100644
index 000000000000..0736452a798b
--- /dev/null
+++ b/dev-python/pyannotate/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>ajak@gentoo.org</email>
+ <name>John Helmert III</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pypi</remote-id>
+ <remote-id type="github">dropbox/pyannotate</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyannotate/pyannotate-1.2.0.ebuild b/dev-python/pyannotate/pyannotate-1.2.0.ebuild
new file mode 100644
index 000000000000..e8e92dfbd717
--- /dev/null
+++ b/dev-python/pyannotate/pyannotate-1.2.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A tool (and pre-commit hook) to automatically upgrade syntax for newer versions of the language."
+HOMEPAGE="https://github.com/dropbox/pyannotate"
+SRC_URI="https://github.com/dropbox/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/mypy_extensions[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest