summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-cors-headers/Manifest1
-rw-r--r--dev-python/django-cors-headers/django-cors-headers-3.14.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/django-cors-headers/Manifest b/dev-python/django-cors-headers/Manifest
index 462d563be57c..3f363d9fae7e 100644
--- a/dev-python/django-cors-headers/Manifest
+++ b/dev-python/django-cors-headers/Manifest
@@ -1 +1,2 @@
DIST django-cors-headers-3.13.0.gh.tar.gz 27361 BLAKE2B 2d0729ae6f0e0ff7c572c5f25482fd88dfa03e8f03a7f640ba32f56208fccb91712cd3067bc3376428469cc7f03dd8003069b79e98dd438fad9e5f4b15cd9c71 SHA512 153ae0d2e0b1e390c72993ca629f7ed521fd907481bb2944ee2f805c0081a1db334fd72f0b3fdb77cbb57b3392691f32564bb646bfb8e388a942a8a3da138a8e
+DIST django-cors-headers-3.14.0.gh.tar.gz 29634 BLAKE2B 08ec6811b8608feecbdaadcc6ce220b1574a4bf16823f939f93eda4ece9df0430b015edc1d0909b980996ff143e036858ca81f524e8d270846881a9c0af25fac SHA512 5ff390bd2fba1b3dff3cea08b10021d0fd100497000b2eaef788fe32c1b8584f1954e470f4aa15cbcf9e4342265633a658b8736de08962bfe0ea9e2068521379
diff --git a/dev-python/django-cors-headers/django-cors-headers-3.14.0.ebuild b/dev-python/django-cors-headers/django-cors-headers-3.14.0.ebuild
new file mode 100644
index 000000000000..c9fcf1c8a4b0
--- /dev/null
+++ b/dev-python/django-cors-headers/django-cors-headers-3.14.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django App that adds CORS (Cross-Origin Resource Sharing) headers to responses"
+HOMEPAGE="
+ https://github.com/adamchainz/django-cors-headers/
+ https://pypi.org/project/django-cors-headers/
+"
+SRC_URI="
+ https://github.com/adamchainz/django-cors-headers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest