summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qt-creator/qt-creator-3.5.1.ebuild')
-rw-r--r--dev-qt/qt-creator/qt-creator-3.5.1.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-qt/qt-creator/qt-creator-3.5.1.ebuild b/dev-qt/qt-creator/qt-creator-3.5.1.ebuild
index d12592aba2e7..c09044eda508 100644
--- a/dev-qt/qt-creator/qt-creator-3.5.1.ebuild
+++ b/dev-qt/qt-creator/qt-creator-3.5.1.ebuild
@@ -80,6 +80,10 @@ PDEPEND="
valgrind? ( dev-util/valgrind )
"
+PATCHES=(
+ "${FILESDIR}/3.5.1-tst_fileutils-parentDir.patch"
+)
+
src_unpack() {
if [[ $(gcc-major-version) -lt 4 ]] || [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 7 ]]; then
eerror "GCC version 4.7 or later is required to build Qt Creator"
@@ -94,6 +98,10 @@ src_unpack() {
}
src_prepare() {
+ # apply patches
+ [[ ${PATCHES[@]} ]] && epatch "${PATCHES[@]}"
+ epatch_user
+
# disable unwanted plugins
for plugin in "${QTC_PLUGINS[@]#[+-]}"; do
if ! use ${plugin%:*}; then