summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtbluetooth/qtbluetooth-5.15.8.ebuild')
-rw-r--r--dev-qt/qtbluetooth/qtbluetooth-5.15.8.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-qt/qtbluetooth/qtbluetooth-5.15.8.ebuild b/dev-qt/qtbluetooth/qtbluetooth-5.15.8.ebuild
new file mode 100644
index 000000000000..e7c437157c60
--- /dev/null
+++ b/dev-qt/qtbluetooth/qtbluetooth-5.15.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=1
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+QT5_MODULE="qtconnectivity"
+inherit qt5-build
+
+DESCRIPTION="Bluetooth support library for the Qt5 framework"
+
+IUSE="qml"
+
+DEPEND="
+ =dev-qt/qtconcurrent-${QT5_PV}*
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtdbus-${QT5_PV}*
+ =dev-qt/qtnetwork-${QT5_PV}*
+ >=net-wireless/bluez-5:=
+ qml? ( =dev-qt/qtdeclarative-${QT5_PV}* )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's/nfc//' src/src.pro || die
+
+ qt_use_disable_mod qml quick src/src.pro
+
+ qt5-build_src_prepare
+}