summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtlocation')
-rw-r--r--dev-qt/qtlocation/Manifest1
-rw-r--r--dev-qt/qtlocation/qtlocation-5.15.10-r1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index d4a9b0956fdc..49b495fbec03 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -1,4 +1,5 @@
DIST qtlocation-5.15.10-gentoo-kde-1.tar.xz 3664 BLAKE2B e2d694772a43ca4bc27c819d8fadf5bab3ddb40644d5a08315faa5af63a7aace6475c2dd2b6d612dcb7705113211cd50e6e83ce79773ec6033767be0fb761346 SHA512 c3917fa4db6316c9e173c475d8606b7fd9dc3cfed29487fa23c9b6df68887d799e6260abc3f5cd144e9d8c1e95e66b0de429bf59f15526639aab4d430c3d439a
DIST qtlocation-everywhere-opensource-src-5.15.10.tar.xz 6552240 BLAKE2B 1e44bdafcde01294424cef1963924b85fc4f3cc8ab19b1ae37d79d10cb0bbb1a482f592725fa28e0f039fc84cb2167df4d15e23e4060bd7c49df013c54322665 SHA512 e4fb56ddd2dc50024f02de84323c3299788eb6632672e1bc52ef1399ccf9d0af34b0104548cb108fb372870057426b0cdd52052ad91ba45fc7f8098a675f29a4
DIST qtlocation-everywhere-src-6.5.2.tar.xz 3032488 BLAKE2B c8cd34980b0f78326fb70bf76a04094cf3e27afbd6aed6d982ce30abfa9dc4250d164dbe11c1027bedcdeee3b7c907c3716e88f16eeae173b846ccdf2c38d458 SHA512 b1e5c1813deb8a4eb9f8548afa935f1a2145ed3168f0276493ea501057fd4f70b8980ae387248a59e50f0e450ae245a04cd8636fb61d37af9c3634ff1cdd24f3
+DIST qtlocation-mapboxgl-5.15.10-4c88f2c0.tar.gz 3726387 BLAKE2B e9b818505ace86516262d1407450c14be82122bb91363a57708795844089371ac7d511a857f713c7cb4e6f8b54867aab0bc5dcdb9c49aa28aa3f8363271378e0 SHA512 e4d9133db892fd8b7b1bcf584bf7dae30c0f0353f3b0a696a6cabc9485067f262d42554b583640521734498572e5480b5e8d0143d5be47bb92077f3192fefa4d
DIST qtlocation-mapboxgl-5.15.10-5a07e196.tar.gz 3726230 BLAKE2B 9dbe08088a55bc1da4952a628af987b3b056615e883983d3a5e2eb392ce4aff16bfd753f84bbad07f9a415fbd275ec9933a64b6bcfd27ea6d8adced6d2adcac7 SHA512 ec3de81f643388690eda45d073a9c6f908d8efeff30cd062d9afcd1f94c6b45b301327747928d45b4047ce04b7df5b0afaf9e8942e22660711a5ac49787829eb
diff --git a/dev-qt/qtlocation/qtlocation-5.15.10-r1.ebuild b/dev-qt/qtlocation/qtlocation-5.15.10-r1.ebuild
new file mode 100644
index 000000000000..0e9f034eb269
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.15.10-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=1
+ MAPBOXGL_COMMIT=4c88f2c0e61daa89f584a8a9a3eba210221c6920
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+inherit qt5-build
+
+DESCRIPTION="Location (places, maps, navigation) library for the Qt5 framework"
+[[ ${QT5_BUILD_TYPE} == release ]] &&
+SRC_URI+=" https://invent.kde.org/qt/qt/${PN}-mapboxgl/-/archive/${MAPBOXGL_COMMIT}/${PN}-mapboxgl-${MAPBOXGL_COMMIT}.tar.gz -> ${PN}-mapboxgl-${PV}-${MAPBOXGL_COMMIT:0:8}.tar.gz"
+
+IUSE=""
+
+RDEPEND="
+ dev-libs/icu:=
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtdeclarative-${QT5_PV}*
+ =dev-qt/qtgui-${QT5_PV}*
+ =dev-qt/qtnetwork-${QT5_PV}*
+ =dev-qt/qtpositioning-${QT5_PV}*[qml]
+ =dev-qt/qtsql-${QT5_PV}*
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ =dev-qt/qtconcurrent-${QT5_PV}*
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/3rdparty/mapbox-gl-native
+ src/location
+ src/imports/location
+ src/imports/locationlabs
+ src/plugins/geoservices
+)
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+src_prepare() {
+ rm -rf src/3rdparty/mapbox-gl-native/* || die
+ mv "${WORKDIR}"/${PN}-mapboxgl-${MAPBOXGL_COMMIT}/* src/3rdparty/mapbox-gl-native || die
+ qt5-build_src_prepare
+}
+fi
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ qt5_configure_oos_quirk qtlocation-config.pri src/location
+ qt5-build_src_configure
+}