summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtpaths/qtpaths-5.15.13.ebuild')
-rw-r--r--dev-qt/qtpaths/qtpaths-5.15.13.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-qt/qtpaths/qtpaths-5.15.13.ebuild b/dev-qt/qtpaths/qtpaths-5.15.13.ebuild
new file mode 100644
index 000000000000..18d2be6723f4
--- /dev/null
+++ b/dev-qt/qtpaths/qtpaths-5.15.13.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=1
+ KEYWORDS="amd64 ~arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~sparc x86"
+fi
+
+QT5_MODULE="qttools"
+inherit qt5-build
+
+DESCRIPTION="Command line client to QStandardPaths"
+
+IUSE=""
+
+DEPEND="=dev-qt/qtcore-${QT5_PV}*"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/qtpaths
+)
+
+src_install() {
+ qt5-build_src_install
+ qt5_symlink_binary_to_path qtpaths 5
+}