summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtlocation/files/qtlocation-5.14.2-gcc-10.patch36
-rw-r--r--dev-qt/qtlocation/qtlocation-5.14.2.ebuild2
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/files/qtlocation-5.14.2-gcc-10.patch b/dev-qt/qtlocation/files/qtlocation-5.14.2-gcc-10.patch
new file mode 100644
index 000000000000..e7cc6f70d055
--- /dev/null
+++ b/dev-qt/qtlocation/files/qtlocation-5.14.2-gcc-10.patch
@@ -0,0 +1,36 @@
+From 0853378b2f2de82c59501e31d18906694ec6e27e Mon Sep 17 00:00:00 2001
+From: Bruno de Oliveira Abinader <bruno@mapbox.com>
+Date: Wed, 22 Apr 2020 19:54:53 +0300
+Subject: Fix compilation issues on GCC 9
+
+---
+ platform/default/bidi.cpp | 1 +
+ src/mbgl/util/convert.cpp | 2 ++
+ 2 files changed, 3 insertions(+)
+
+diff --git a/src/3rdparty/mapbox-gl-native/platform/default/bidi.cpp b/src/3rdparty/mapbox-gl-native/platform/default/bidi.cpp
+index d475c387b..c1710a6f1 100644
+--- a/src/3rdparty/mapbox-gl-native/platform/default/bidi.cpp
++++ b/src/3rdparty/mapbox-gl-native/platform/default/bidi.cpp
+@@ -5,6 +5,7 @@
+ #include <unicode/ushape.h>
+
+ #include <memory>
++#include <stdexcept>
+
+ namespace mbgl {
+
+diff --git a/src/3rdparty/mapbox-gl-native/src/mbgl/util/convert.cpp b/src/3rdparty/mapbox-gl-native/src/mbgl/util/convert.cpp
+index 97bfe9108..510ff2386 100644
+--- a/src/3rdparty/mapbox-gl-native/src/mbgl/util/convert.cpp
++++ b/src/3rdparty/mapbox-gl-native/src/mbgl/util/convert.cpp
+@@ -1,5 +1,7 @@
+ #include <mbgl/util/convert.hpp>
+
++#include <cstdint>
++
+ namespace mbgl {
+ namespace util {
+
+--
+cgit v1.2.1
diff --git a/dev-qt/qtlocation/qtlocation-5.14.2.ebuild b/dev-qt/qtlocation/qtlocation-5.14.2.ebuild
index d7e1e290a78a..33f50e77187d 100644
--- a/dev-qt/qtlocation/qtlocation-5.14.2.ebuild
+++ b/dev-qt/qtlocation/qtlocation-5.14.2.ebuild
@@ -37,6 +37,8 @@ QT5_TARGET_SUBDIRS=(
src/plugins/geoservices
)
+PATCHES=( "${FILESDIR}/${P}-gcc-10.patch" ) # bug 722102
+
src_configure() {
# src/plugins/geoservices requires files that are only generated when
# qmake is run in the root directory. Bug 633776.