summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/ament_cmake_libraries/ament_cmake_libraries-0.8.1.ebuild')
-rw-r--r--dev-ros/ament_cmake_libraries/ament_cmake_libraries-0.8.1.ebuild23
1 files changed, 18 insertions, 5 deletions
diff --git a/dev-ros/ament_cmake_libraries/ament_cmake_libraries-0.8.1.ebuild b/dev-ros/ament_cmake_libraries/ament_cmake_libraries-0.8.1.ebuild
index 927b7ae06922..5e721bb81ef3 100644
--- a/dev-ros/ament_cmake_libraries/ament_cmake_libraries-0.8.1.ebuild
+++ b/dev-ros/ament_cmake_libraries/ament_cmake_libraries-0.8.1.ebuild
@@ -8,22 +8,35 @@ PYTHON_COMPAT=( python{3_6,3_7} )
inherit cmake-utils python-r1
ROS_PN="ament_cmake"
-DESCRIPTION="The core of the ament buildsystem in CMake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The functionality to deduplicate libraries in the ament buildsystem"
HOMEPAGE="https://github.com/ament/ament_cmake"
-SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
IUSE=""
DEPEND="
dev-ros/ament_cmake_core[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
"
RDEPEND="${DEPEND}"
-BDEPEND="${PYTHON_DEPS}"
+BDEPEND="${DEPEND}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
src_configure() {
# This is a build tool that does not install python-related files