summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/ament_lint_auto')
-rw-r--r--dev-ros/ament_lint_auto/Manifest1
-rw-r--r--dev-ros/ament_lint_auto/ament_lint_auto-0.10.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-ros/ament_lint_auto/Manifest b/dev-ros/ament_lint_auto/Manifest
index 6b51d9c9d13e..8dd9c04fcb27 100644
--- a/dev-ros/ament_lint_auto/Manifest
+++ b/dev-ros/ament_lint_auto/Manifest
@@ -1 +1,2 @@
+DIST ament_lint-0.10.0.tar.gz 219525 BLAKE2B 6ba7a32d0678e545c24b74ed187991140c34a363ad855e469f0e20f8a088b7cc939bbd187566233e099576e4c2b899d7d75edf311d3026234222078968be7ce6 SHA512 565413fa325317e6f00ce18051eb13556d1d50144d2c8f62368e5505455ef7f9fae3a69e8d723a3949e44b1f9e638741ae6d9b87687df81a661eb804365200f8
DIST ament_lint-0.9.5.tar.gz 218077 BLAKE2B bc49fdb517bcdab815cfd4c945e9d61a9b53d4b600361ced9161b6186bfb74fdb3d5ed5f14a48f22a91fd0737333dc76cc7d55044c204ea864b53dd68e32254b SHA512 1c5b3acb31a07f4613e13fe69f6dad1981df0dc596e46a07651322a4da1c5f3db40befb775aa42aabc1f6808132c950c9f37950f64b4196e3c1b40871e25a384
diff --git a/dev-ros/ament_lint_auto/ament_lint_auto-0.10.0.ebuild b/dev-ros/ament_lint_auto/ament_lint_auto-0.10.0.ebuild
new file mode 100644
index 000000000000..120c90db0dd4
--- /dev/null
+++ b/dev-ros/ament_lint_auto/ament_lint_auto-0.10.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit cmake python-any-r1
+
+ROS_PN="ament_lint"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_lint"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The auto-magic functions for ease to use of the ament linters"
+HOMEPAGE="https://github.com/ament/ament_lint"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND="
+ dev-ros/ament_cmake_core
+ dev-ros/ament_cmake_test
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+"
+
+python_check_deps() {
+ has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+}