summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/clear_costmap_recovery/clear_costmap_recovery-1.14.0.ebuild')
-rw-r--r--dev-ros/clear_costmap_recovery/clear_costmap_recovery-1.14.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/clear_costmap_recovery/clear_costmap_recovery-1.14.0.ebuild b/dev-ros/clear_costmap_recovery/clear_costmap_recovery-1.14.0.ebuild
new file mode 100644
index 000000000000..6ff2d9653dee
--- /dev/null
+++ b/dev-ros/clear_costmap_recovery/clear_costmap_recovery-1.14.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Recovery behavior that attempts to clear space by reverting the costmaps to the static map"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/costmap_2d-1.13.1
+ dev-ros/nav_core
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-cpp/eigen:3
+ sci-libs/pcl
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+ test? ( dev-ros/rostest dev-cpp/gtest )
+"