summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.8.8.ebuild')
-rw-r--r--dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.8.8.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.8.8.ebuild b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.8.8.ebuild
new file mode 100644
index 000000000000..c01522baab44
--- /dev/null
+++ b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.8.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Aggregates ROS diagnostics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/rospy
+ dev-ros/rostest
+ dev-ros/xmlrpcpp
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest )"