summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.9.3.ebuild')
-rw-r--r--dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.9.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.9.3.ebuild b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.9.3.ebuild
new file mode 100644
index 000000000000..650ad537d33a
--- /dev/null
+++ b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.9.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Aggregates ROS diagnostics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-ros/roscpp
+ dev-ros/rospy
+ dev-ros/rostest
+ dev-ros/xmlrpcpp
+ dev-ros/bondcpp
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest )"