summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.7.2.ebuild')
-rw-r--r--dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.7.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.7.2.ebuild b/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.7.2.ebuild
new file mode 100644
index 000000000000..8b133aada32e
--- /dev/null
+++ b/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.7.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/dynamic_reconfigure"
+KEYWORDS="~amd64 ~arm"
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a means to change node parameters at runtime"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads(+)]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-cpp/gtest
+ dev-ros/roslaunch
+ )
+"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}