summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/filters/filters-1.7.4-r1.ebuild')
-rw-r--r--dev-ros/filters/filters-1.7.4-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/filters/filters-1.7.4-r1.ebuild b/dev-ros/filters/filters-1.7.4-r1.ebuild
new file mode 100644
index 000000000000..d1804c1bcd46
--- /dev/null
+++ b/dev-ros/filters/filters-1.7.4-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/filters"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Standardized interface for processing data as a sequence of filters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/roscpp
+ dev-libs/boost:=[threads]
+ dev-ros/pluginlib"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/tests.patch" "${FILESDIR}/rostest.patch" )