summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/hector_geotiff/hector_geotiff-9999.ebuild')
-rw-r--r--dev-ros/hector_geotiff/hector_geotiff-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-ros/hector_geotiff/hector_geotiff-9999.ebuild b/dev-ros/hector_geotiff/hector_geotiff-9999.ebuild
index 1bc71fd4e8be..0fd828ef8d7d 100644
--- a/dev-ros/hector_geotiff/hector_geotiff-9999.ebuild
+++ b/dev-ros/hector_geotiff/hector_geotiff-9999.ebuild
@@ -1,33 +1,33 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
inherit ros-catkin
-DESCRIPTION="Node to save occupancy grid map, robot trajectory and object of interest data to GeoTiff images"
+DESCRIPTION="Saves occupancy grid map, robot trajectory and object data to GeoTiff images"
LICENSE="BSD"
SLOT="0"
IUSE=""
RDEPEND="
dev-ros/hector_map_tools
- dev-ros/hector_nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/pluginlib
dev-libs/tinyxml2:=
dev-libs/console_bridge:=
dev-ros/roscpp
- dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
dev-libs/boost:=
"
DEPEND="${RDEPEND}
+ dev-ros/hector_nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-cpp/eigen:3"
PATCHES=( "${FILESDIR}/qt5.patch" )