summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/hector_geotiff')
-rw-r--r--dev-ros/hector_geotiff/Manifest1
-rw-r--r--dev-ros/hector_geotiff/files/qt5.patch91
-rw-r--r--dev-ros/hector_geotiff/hector_geotiff-0.4.1.ebuild33
-rw-r--r--dev-ros/hector_geotiff/hector_geotiff-9999.ebuild33
-rw-r--r--dev-ros/hector_geotiff/metadata.xml11
5 files changed, 0 insertions, 169 deletions
diff --git a/dev-ros/hector_geotiff/Manifest b/dev-ros/hector_geotiff/Manifest
deleted file mode 100644
index 703025b72310..000000000000
--- a/dev-ros/hector_geotiff/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST hector_slam-0.4.1.tar.gz 66772 BLAKE2B ad6f5596ea1fca2ed68017534280a4d622179de8df4c039e95f3e87a0e591212944d65e4d507194eb33584f7f55cba4fe398b19f5a22bfb3afce1b2406d1635d SHA512 bd0932971114f13c41c6e346756f2c95cc0a9a011d11202792a6f837757a144355e05c3e7ed1afa574b743166a78f1a7855c5693b0c57378611e50c386c2483e
diff --git a/dev-ros/hector_geotiff/files/qt5.patch b/dev-ros/hector_geotiff/files/qt5.patch
deleted file mode 100644
index 07b44ef23a13..000000000000
--- a/dev-ros/hector_geotiff/files/qt5.patch
+++ /dev/null
@@ -1,91 +0,0 @@
-Index: hector_geotiff/CMakeLists.txt
-===================================================================
---- hector_geotiff.orig/CMakeLists.txt
-+++ hector_geotiff/CMakeLists.txt
-@@ -9,7 +9,7 @@ find_package(catkin REQUIRED COMPONENTS
- ## System dependencies are found with CMake's conventions
- # find_package(Boost REQUIRED COMPONENTS system)
-
--find_package(Qt4 4.6 COMPONENTS QtCore QtGui REQUIRED)
-+find_package(Qt5 5.7 COMPONENTS Core Gui Widgets REQUIRED)
-
- # Find Eigen3 (from http://wiki.ros.org/jade/Migration)
- find_package(Eigen3)
-@@ -24,8 +24,7 @@ else()
- set(EIGEN3_INCLUDE_DIRS ${EIGEN3_INCLUDE_DIR})
- endif()
-
--include(${QT_USE_FILE})
--
-+add_compile_options(-fPIC)
-
- ## Uncomment this if the package has a setup.py. This macro ensures
- ## modules and global scripts declared therein get installed
-@@ -82,10 +81,14 @@ include_directories(include include/hect
- include_directories(
- ${catkin_INCLUDE_DIRS}
- ${EIGEN3_INCLUDE_DIRS}
-+ ${Qt5Core_INCLUDE_DIRS}
-+ ${Qt5Widgets_INCLUDE_DIRS}
-+ ${Qt5Gui_INCLUDE_DIRS}
- )
-
- add_library(geotiff_writer src/geotiff_writer/geotiff_writer.cpp)
--target_link_libraries(geotiff_writer ${catkin_LIBRARIES} ${QT_LIBRARIES})
-+target_link_libraries(geotiff_writer ${catkin_LIBRARIES} ${Qt5Core_LIBRARIES}
-+ ${Qt5Widgets_LIBRARIES} ${Qt5Gui_LIBRARIES})
- add_dependencies(geotiff_writer ${catkin_EXPORTED_TARGETS})
-
- add_executable(geotiff_saver src/geotiff_saver.cpp)
-Index: hector_geotiff/include/hector_geotiff/geotiff_writer.h
-===================================================================
---- hector_geotiff.orig/include/hector_geotiff/geotiff_writer.h
-+++ hector_geotiff/include/hector_geotiff/geotiff_writer.h
-@@ -37,7 +37,7 @@
- #include <nav_msgs/MapMetaData.h>
-
- #include <QtGui/QImage>
--#include <QtGui/QApplication>
-+#include <QtWidgets/QApplication>
- #include <QtGui/QFont>
- #include <QtGui/QPen>
-
-Index: hector_geotiff/src/geotiff_node.cpp
-===================================================================
---- hector_geotiff.orig/src/geotiff_node.cpp
-+++ hector_geotiff/src/geotiff_node.cpp
-@@ -40,7 +40,7 @@
-
- #include <Eigen/Geometry>
-
--#include <QtGui/QApplication>
-+#include <QtWidgets/QApplication>
-
- #include <hector_map_tools/HectorMapTools.h>
-
-Index: hector_geotiff/src/geotiff_saver.cpp
-===================================================================
---- hector_geotiff.orig/src/geotiff_saver.cpp
-+++ hector_geotiff/src/geotiff_saver.cpp
-@@ -34,7 +34,7 @@
-
- #include <Eigen/Geometry>
-
--#include <QtGui/QApplication>
-+#include <QtWidgets/QApplication>
-
- #include <hector_map_tools/HectorMapTools.h>
-
-Index: hector_geotiff/src/geotiff_writer/geotiff_writer.cpp
-===================================================================
---- hector_geotiff.orig/src/geotiff_writer/geotiff_writer.cpp
-+++ hector_geotiff/src/geotiff_writer/geotiff_writer.cpp
-@@ -31,7 +31,7 @@
-
- #include <QtGui/QPainter>
- #include <QtGui/QImageWriter>
--#include <QtGui/QApplication>
-+#include <QtWidgets/QApplication>
- #include <QtCore/QFile>
- //#include <QtCore/QDateTime>
- #include <QtCore/QTime>
diff --git a/dev-ros/hector_geotiff/hector_geotiff-0.4.1.ebuild b/dev-ros/hector_geotiff/hector_geotiff-0.4.1.ebuild
deleted file mode 100644
index 0fd828ef8d7d..000000000000
--- a/dev-ros/hector_geotiff/hector_geotiff-0.4.1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="Saves occupancy grid map, robot trajectory and object data to GeoTiff images"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/hector_map_tools
- dev-ros/pluginlib
- dev-libs/tinyxml2:=
- dev-libs/console_bridge:=
- dev-ros/roscpp
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- dev-libs/boost:=
-"
-DEPEND="${RDEPEND}
- dev-ros/hector_nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-cpp/eigen:3"
-
-PATCHES=( "${FILESDIR}/qt5.patch" )
diff --git a/dev-ros/hector_geotiff/hector_geotiff-9999.ebuild b/dev-ros/hector_geotiff/hector_geotiff-9999.ebuild
deleted file mode 100644
index 0fd828ef8d7d..000000000000
--- a/dev-ros/hector_geotiff/hector_geotiff-9999.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="Saves occupancy grid map, robot trajectory and object data to GeoTiff images"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/hector_map_tools
- dev-ros/pluginlib
- dev-libs/tinyxml2:=
- dev-libs/console_bridge:=
- dev-ros/roscpp
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- dev-libs/boost:=
-"
-DEPEND="${RDEPEND}
- dev-ros/hector_nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-cpp/eigen:3"
-
-PATCHES=( "${FILESDIR}/qt5.patch" )
diff --git a/dev-ros/hector_geotiff/metadata.xml b/dev-ros/hector_geotiff/metadata.xml
deleted file mode 100644
index 29147f0be960..000000000000
--- a/dev-ros/hector_geotiff/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>ros@gentoo.org</email>
- <name>Gentoo ROS Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">tu-darmstadt-ros-pkg/hector_slam</remote-id>
- </upstream>
-</pkgmetadata>