summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/image_proc/image_proc-1.12.15.ebuild')
-rw-r--r--dev-ros/image_proc/image_proc-1.12.15.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/image_proc/image_proc-1.12.15.ebuild b/dev-ros/image_proc/image_proc-1.12.15.ebuild
new file mode 100644
index 000000000000..fc4695ace629
--- /dev/null
+++ b/dev-ros/image_proc/image_proc-1.12.15.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Single image rectification and color processing"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure
+ dev-ros/image_geometry
+ dev-ros/image_transport
+ dev-ros/nodelet
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ media-libs/opencv
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}"