summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/joint_state_publisher/joint_state_publisher-1.12.3.ebuild')
-rw-r--r--dev-ros/joint_state_publisher/joint_state_publisher-1.12.3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/joint_state_publisher/joint_state_publisher-1.12.3.ebuild b/dev-ros/joint_state_publisher/joint_state_publisher-1.12.3.ebuild
new file mode 100644
index 000000000000..4d1c07e2b056
--- /dev/null
+++ b/dev-ros/joint_state_publisher/joint_state_publisher-1.12.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/robot_model"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tool for setting and publishing joint state values for a given URDF"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"