summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/move_base/move_base-1.14.2.ebuild')
-rw-r--r--dev-ros/move_base/move_base-1.14.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/move_base/move_base-1.14.2.ebuild b/dev-ros/move_base/move_base-1.14.2.ebuild
new file mode 100644
index 000000000000..3a9903df454c
--- /dev/null
+++ b/dev-ros/move_base/move_base-1.14.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Given a goal in the world, will attempt to reach it with a mobile base"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/costmap_2d-1.13.1
+ dev-ros/roscpp
+ dev-ros/pluginlib
+ dev-ros/actionlib
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/nav_core
+ dev-ros/tf
+ dev-ros/move_base_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-cpp/eigen:3
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules"