summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/poco_vendor/poco_vendor-1.2.0.ebuild')
-rw-r--r--dev-ros/poco_vendor/poco_vendor-1.2.0.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/dev-ros/poco_vendor/poco_vendor-1.2.0.ebuild b/dev-ros/poco_vendor/poco_vendor-1.2.0.ebuild
index b6214810f35f..5e44119b2a2b 100644
--- a/dev-ros/poco_vendor/poco_vendor-1.2.0.ebuild
+++ b/dev-ros/poco_vendor/poco_vendor-1.2.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python{3_7,3_8} )
-inherit cmake-utils python-any-r1
+inherit cmake python-any-r1
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
@@ -28,10 +28,16 @@ fi
IUSE=""
DEPEND="
- dev-libs/poco
+ >=dev-libs/poco-1.6.1
+ dev-libs/libpcre
+ sys-libs/zlib
"
RDEPEND="${DEPEND}"
BDEPEND="
$(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
${PYTHON_DEPS}
"
+
+python_check_deps() {
+ has_version "ros-meta/ament_cmake[${PYTHON_USEDEP}]"
+}