summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/polled_camera/polled_camera-1.11.10.ebuild')
-rw-r--r--dev-ros/polled_camera/polled_camera-1.11.10.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/polled_camera/polled_camera-1.11.10.ebuild b/dev-ros/polled_camera/polled_camera-1.11.10.ebuild
new file mode 100644
index 000000000000..825bf06a313d
--- /dev/null
+++ b/dev-ros/polled_camera/polled_camera-1.11.10.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/sensor_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="C++ helper classes for implementing a polled camera driver node and requesting images from it"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/image_transport
+ dev-ros/rosconsole
+"
+DEPEND="${RDEPEND}"