summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/python_qt_binding/python_qt_binding-0.3.0.ebuild')
-rw-r--r--dev-ros/python_qt_binding/python_qt_binding-0.3.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/python_qt_binding/python_qt_binding-0.3.0.ebuild b/dev-ros/python_qt_binding/python_qt_binding-0.3.0.ebuild
new file mode 100644
index 000000000000..b7675d83d1e4
--- /dev/null
+++ b/dev-ros/python_qt_binding/python_qt_binding-0.3.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/python_qt_binding"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit ros-catkin
+
+DESCRIPTION="Infrastructure for an integrated graphical user interface based on Qt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"