summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/qt_gui_app/qt_gui_app-0.3.0.ebuild')
-rw-r--r--dev-ros/qt_gui_app/qt_gui_app-0.3.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/qt_gui_app/qt_gui_app-0.3.0.ebuild b/dev-ros/qt_gui_app/qt_gui_app-0.3.0.ebuild
new file mode 100644
index 000000000000..dae27ba2cc8c
--- /dev/null
+++ b/dev-ros/qt_gui_app/qt_gui_app-0.3.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Main to start an instance of the integrated graphical user interface provided by qt_gui"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/qt_gui-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"