summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rosconsole/rosconsole-1.13.4.ebuild')
-rw-r--r--dev-ros/rosconsole/rosconsole-1.13.4.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-ros/rosconsole/rosconsole-1.13.4.ebuild b/dev-ros/rosconsole/rosconsole-1.13.4.ebuild
deleted file mode 100644
index f6a79d44be2f..000000000000
--- a/dev-ros/rosconsole/rosconsole-1.13.4.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-ROS_REPO_URI="https://github.com/ros/ros_comm"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=tools/${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="ROS console output library"
-LICENSE="BSD"
-SLOT="0"
-IUSE="+log4cxx glog"
-
-RDEPEND="
- dev-ros/cpp_common
- dev-ros/rostime
- dev-ros/rosunit
- dev-libs/boost:=[threads]
- log4cxx? ( dev-libs/log4cxx )
- !log4cxx? ( glog? ( dev-cpp/glog ) )
-"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- local ROSCONSOLE_BACKEND=""
- if use log4cxx; then
- ROSCONSOLE_BACKEND="log4cxx"
- elif use glog; then
- ROSCONSOLE_BACKEND="glog"
- else
- ROSCONSOLE_BACKEND="print"
- fi
- local mycatkincmakeargs=( "-DROSCONSOLE_BACKEND=${ROSCONSOLE_BACKEND}" )
- ros-catkin_src_configure
-}