summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rosparam/rosparam-1.14.2.ebuild')
-rw-r--r--dev-ros/rosparam/rosparam-1.14.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/rosparam/rosparam-1.14.2.ebuild b/dev-ros/rosparam/rosparam-1.14.2.ebuild
new file mode 100644
index 000000000000..8f4a32442ac6
--- /dev/null
+++ b/dev-ros/rosparam/rosparam-1.14.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for getting and setting ROS Parameters on the parameter server"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"