summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rostopic/rostopic-1.12.5.ebuild')
-rw-r--r--dev-ros/rostopic/rostopic-1.12.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/rostopic/rostopic-1.12.5.ebuild b/dev-ros/rostopic/rostopic-1.12.5.ebuild
new file mode 100644
index 000000000000..b03d11e04d0e
--- /dev/null
+++ b/dev-ros/rostopic/rostopic-1.12.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for displaying debug information about ROS Topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"