summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/test_rosparam/test_rosparam-1.12.2.ebuild')
-rw-r--r--dev-ros/test_rosparam/test_rosparam-1.12.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/test_rosparam/test_rosparam-1.12.2.ebuild b/dev-ros/test_rosparam/test_rosparam-1.12.2.ebuild
new file mode 100644
index 000000000000..49ec6da5c1bf
--- /dev/null
+++ b/dev-ros/test_rosparam/test_rosparam-1.12.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosparam"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-ros/rosparam[${PYTHON_USEDEP}]
+ )"