summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/tf2_py/tf2_py-0.7.5.ebuild')
-rw-r--r--dev-ros/tf2_py/tf2_py-0.7.5.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/tf2_py/tf2_py-0.7.5.ebuild b/dev-ros/tf2_py/tf2_py-0.7.5.ebuild
new file mode 100644
index 000000000000..2bae9efadc93
--- /dev/null
+++ b/dev-ros/tf2_py/tf2_py-0.7.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="TF2 python bindings"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf2
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"