summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.6.5.ebuild')
-rw-r--r--dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.6.5.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.6.5.ebuild b/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.6.5.ebuild
new file mode 100644
index 000000000000..48bdaf11cbeb
--- /dev/null
+++ b/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.6.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Transform sensor_msgs with tf. Most notably, PointCloud2"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf2_ros[${PYTHON_USEDEP}]
+ dev-ros/tf2
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )
+ dev-ros/cmake_modules"