summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/image_geometry/files/image_geometry-1.12.0-gcc-6.patch22
-rw-r--r--dev-ros/image_geometry/image_geometry-1.12.0-r1.ebuild3
-rw-r--r--dev-ros/image_geometry/image_geometry-1.12.1.ebuild1
3 files changed, 25 insertions, 1 deletions
diff --git a/dev-ros/image_geometry/files/image_geometry-1.12.0-gcc-6.patch b/dev-ros/image_geometry/files/image_geometry-1.12.0-gcc-6.patch
new file mode 100644
index 000000000000..1ce69439bb4e
--- /dev/null
+++ b/dev-ros/image_geometry/files/image_geometry-1.12.0-gcc-6.patch
@@ -0,0 +1,22 @@
+commit ead421b85eeb750cbf7988657015296ed6789bcf
+Author: Hodorgasm <nsane457@gmail.com>
+Date: Mon Sep 19 20:27:51 2016 -0400
+
+ Fix "stdlib.h: No such file or directory" errors in GCC-6
+
+ Including '-isystem /usr/include' breaks building with GCC-6.
+ See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129
+
+diff --git a/image_geometry/CMakeLists.txt b/image_geometry/CMakeLists.txt
+index 3c9cb30..e7c9eea 100644
+--- a/image_geometry/CMakeLists.txt
++++ b/image_geometry/CMakeLists.txt
+@@ -12,7 +12,7 @@ catkin_package(CATKIN_DEPENDS sensor_msgs
+
+ catkin_python_setup()
+
+-include_directories(SYSTEM ${catkin_INCLUDE_DIRS}
++include_directories(${catkin_INCLUDE_DIRS}
+ ${OpenCV_INCLUDE_DIRS}
+ )
+ include_directories(include)
diff --git a/dev-ros/image_geometry/image_geometry-1.12.0-r1.ebuild b/dev-ros/image_geometry/image_geometry-1.12.0-r1.ebuild
index 565d79c1fcd5..7f6289968035 100644
--- a/dev-ros/image_geometry/image_geometry-1.12.0-r1.ebuild
+++ b/dev-ros/image_geometry/image_geometry-1.12.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -21,3 +21,4 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? ( dev-python/nose[${PYTHON_USEDEP}] dev-cpp/gtest )"
+PATCHES=("${FILESDIR}"/${PN}-1.12.0-gcc-6.patch)
diff --git a/dev-ros/image_geometry/image_geometry-1.12.1.ebuild b/dev-ros/image_geometry/image_geometry-1.12.1.ebuild
index 706a2dd154f7..7f6289968035 100644
--- a/dev-ros/image_geometry/image_geometry-1.12.1.ebuild
+++ b/dev-ros/image_geometry/image_geometry-1.12.1.ebuild
@@ -21,3 +21,4 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? ( dev-python/nose[${PYTHON_USEDEP}] dev-cpp/gtest )"
+PATCHES=("${FILESDIR}"/${PN}-1.12.0-gcc-6.patch)