summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/actionmailbox/actionmailbox-7.0.4.3.ebuild')
-rw-r--r--dev-ruby/actionmailbox/actionmailbox-7.0.4.3.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-ruby/actionmailbox/actionmailbox-7.0.4.3.ebuild b/dev-ruby/actionmailbox/actionmailbox-7.0.4.3.ebuild
index d99b51207331..ce6211577954 100644
--- a/dev-ruby/actionmailbox/actionmailbox-7.0.4.3.ebuild
+++ b/dev-ruby/actionmailbox/actionmailbox-7.0.4.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27 ruby30"
+USE_RUBY="ruby27 ruby30 ruby31"
RUBY_FAKEGEM_RECIPE_DOC="none"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
@@ -40,6 +40,7 @@ ruby_add_rdepend "
ruby_add_bdepend "test? (
dev-ruby/bundler
<dev-ruby/mail-2.8
+ <dev-ruby/minitest-5.16
dev-ruby/mocha
dev-ruby/propshaft
dev-ruby/rexml
@@ -50,7 +51,7 @@ ruby_add_bdepend "test? (
all_ruby_prepare() {
# Remove items from the common Gemfile that we don't need for this
# test run. This also requires handling some gemspecs.
- sed -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql2\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|sass-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webdrivers\|webrick\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|capybara\|webpacker\|bootsnap\|dalli\|connection_pool\)/ s:^:#:" \
+ sed -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql2\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|sass-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webdrivers\|webrick\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|rack-test\|capybara\|webpacker\|bootsnap\|dalli\|connection_pool\|terser\)/ s:^:#:" \
-e '/stimulus-rails/,/tailwindcss-rails/ s:^:#:' \
-e '/group :\(cable\|doc\|job\|rubocop\|storage\|test\)/,/^end/ s:^:#:' \
-e '10igem "mail", "< 2.8"' \