summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/activeldap')
-rw-r--r--dev-ruby/activeldap/Manifest1
-rw-r--r--dev-ruby/activeldap/activeldap-6.0.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/activeldap/Manifest b/dev-ruby/activeldap/Manifest
index 7670c25ea4e3..59e8a312a31e 100644
--- a/dev-ruby/activeldap/Manifest
+++ b/dev-ruby/activeldap/Manifest
@@ -2,3 +2,4 @@ DIST activeldap-5.2.4.gem 226304 BLAKE2B f13b5a1cf423b44087d55d3a4957be1444d598a
DIST activeldap-6.0.0.gem 226304 BLAKE2B ea200a672e1d77cb2eeca343479d39652441403737db9e1fbed14e594749cf33e00e8ca98ffaaa5f473e683faacc2f8d0b046b1ecb3dedf04efa7a23379f7439 SHA512 8b3ce2356612be4093210391102fb5fea51ba9e33ed9ee8281445d8bd13574af88cffbd35122b8cca69ea6799dd31be8fb2f2086f6ed773078b877a4c2ac163d
DIST activeldap-6.0.1.gem 226304 BLAKE2B e61ab86d1a39313f3f34debfde47e4499579273b666ceafc51e3a62cb73293d31a124dbf821428ac33437ca8e604bb4f4c1e1e43b8be58b9a67a73872b6634b8 SHA512 baf3ae0975348f94b00186a6c8569aa9371ae28f5a53654f18da9e6eb8eb50750730c1813c45318148eefa0a37fdb06d27efe13293ab4386637e0fbc1906334a
DIST activeldap-6.0.2.gem 226304 BLAKE2B 513ee26d37292ede2142561d36039747df7d50211151776c14d140fe565adcb3a6005c0923ca3a6d65befa72f91a7e9eff19fa1e1cf35c95111285f5d37de264 SHA512 817a394f3715c53b3ad67fa063c96d0974855be3547daf378064559fc690a0471322a8869fa7d6110661813da50a150c54f8a3b69d3a64d00e64d48ad7125788
+DIST activeldap-6.0.3.gem 227328 BLAKE2B 71819172fcf792631cd958c7329ac1581ae7c3887dc71b76efa9836d2a39e7bac4d4d4dd80c15760f0ed13afc0ee66eecb8546470cf45c7ba45203f94f620b7d SHA512 6b7148d23f2841bf614ac9d853e1bf18f50f2512efcd2397b10c07c30d3418b910717aba3fcfdc4ff67fadbbbd5d29b2ba4261fc126d8498e66e389fce13db3b
diff --git a/dev-ruby/activeldap/activeldap-6.0.3.ebuild b/dev-ruby/activeldap/activeldap-6.0.3.ebuild
new file mode 100644
index 000000000000..2c07111cb086
--- /dev/null
+++ b/dev-ruby/activeldap/activeldap-6.0.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="TODO doc/text/*"
+RUBY_FAKEGEM_EXTRAINSTALL="po"
+
+inherit ruby-fakegem
+
+MY_P="${P/ruby-/}"
+DESCRIPTION="ActiveLDAP provides an activerecord inspired object oriented interface to LDAP"
+HOMEPAGE="https://github.com/activeldap/activeldap"
+
+LICENSE="GPL-2"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Most tests require a live LDAP server to run.
+RESTRICT="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/activemodel-5.2.0:*
+ dev-ruby/builder
+ dev-ruby/locale
+ dev-ruby/ruby-gettext
+ dev-ruby/gettext_i18n_rails
+ || ( dev-ruby/ruby-net-ldap >=dev-ruby/ruby-ldap-0.8.2 )"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc doc/text/*
+ dodoc -r examples
+}