summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/activemodel/activemodel-5.2.8.ebuild')
-rw-r--r--dev-ruby/activemodel/activemodel-5.2.8.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-ruby/activemodel/activemodel-5.2.8.ebuild b/dev-ruby/activemodel/activemodel-5.2.8.ebuild
deleted file mode 100644
index 36dfba0c1e2f..000000000000
--- a/dev-ruby/activemodel/activemodel-5.2.8.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby25 ruby26"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem eapi7-ver
-
-DESCRIPTION="Toolkit for building modeling frameworks like Active Record and Active Resource"
-HOMEPAGE="https://github.com/rails/rails"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/activesupport-${PV}:*
-"
-
-ruby_add_bdepend "
- test? (
- ~dev-ruby/railties-${PV}
- dev-ruby/test-unit:2
- dev-ruby/mocha
- >=dev-ruby/bcrypt-ruby-3.1.7
- )"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
- sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
- sed -i -e '2igem "railties", "~> 5.2.0"; gem "psych", "~> 3.0"' test/cases/helper.rb || die
-}