summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/asciidoctor-diagram/asciidoctor-diagram-1.5.11.ebuild')
-rw-r--r--dev-ruby/asciidoctor-diagram/asciidoctor-diagram-1.5.11.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/asciidoctor-diagram/asciidoctor-diagram-1.5.11.ebuild b/dev-ruby/asciidoctor-diagram/asciidoctor-diagram-1.5.11.ebuild
new file mode 100644
index 000000000000..c3548454fb5f
--- /dev/null
+++ b/dev-ruby/asciidoctor-diagram/asciidoctor-diagram-1.5.11.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc LICENSE.txt README.adoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A set of Asciidoctor extensions that enable you to add diagrams"
+HOMEPAGE="https://github.com/asciidoctor/asciidoctor-diagram"
+SRC_URI="https://github.com/asciidoctor/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "=dev-ruby/asciidoctor-1.5*"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/c.formatter/ s:^:#:' spec/test_helper.rb || die
+
+ # Avoid specs for unpackaged tools
+ rm -f spec/{a2s,blockdiag,erd,mermaid,msc,shaape,svgbob,syntrax,umlet,vega,wavedrom}_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+}